[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: gnumach crashing

From: Thomas Schwinge
Subject: Re: gnumach crashing
Date: Thu, 27 Sep 2007 23:56:58 +0200
User-agent: Mutt/1.5.11


On Wed, Sep 26, 2007 at 01:02:20PM -0500, R. Steven Rainwater wrote:
> On Wed, 2007-09-26 at 05:44, Thomas Schwinge wrote:
> > On Tue, Sep 25, 2007 at 04:57:15PM -0500, R. Steven Rainwater wrote:
> Now I've rebuilt gnumach with --enable-kdb and got slightly different
> results. Instead of a reboot, the sytem halts with a visible error
> message:

That's why I suggested that.

> Starting MTA: Panic: zalloc: zone ipc ports exhausted
> Kernel Breakpoint trap, eip 0x1179d7
> Stopped at 0x1179d6: int $3
> Next I rebooted on the working Debian gnumach and set the MTA not to
> start. This time I got a similar crash message when inetd tried to
> start.
> Hurd seems to be crashing at the point when anything that uses the
> network starts up.

What is your installed version of the Debian hurd package?  ``apt-cache
policy hurd'' will tell.

> Possibly because TCP/IP isn't working in my gnumach?

The networking stack is implemented purely as a user space server.  GNU
Mach (roughly) only provides the interface to the hardware.

> I've downloaded the Debian gnumach source package and noticed they have
> at least one patch in there that might affect networking.

You're thinking about the `12_sis900.patch' one?  That's only for
supporting this particular NIC.  What NIC are you using, by the way?

> I hadn't tried that before but in single user mode, everything seems to
> boot up with no problems. It only crashes in multiuser mode. That makes
> sense with the new information above, since it's only crashing when the
> network is accessed.

Correct.  When you run ``devprobe eth0'' in single user mode, what

> > Do you have `/etc/defaults/hurd' configured for the Hurd console to be
> > started?  If yes, then please remove that temporarily and retry.
> Hmmm... if I disable the Hurd console, will I still be able to get to
> some sort of a prompt where I can re-enable it later?

Pietro already answered here.  If you didn't change the default, you're
already using the Mach console and not the Hurd one.


Attachment: signature.asc
Description: Digital signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]