[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: cannot boot subhurd

From: Da Zheng
Subject: Re: cannot boot subhurd
Date: Sat, 02 Jan 2010 12:54:33 +0800
User-agent: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv: Gecko/20091204 Thunderbird/3.0


On 09-12-31 上午11:04, olafBuddenhagen@gmx.net wrote:
>> But it always worked before. I can also mount /dev/hd1 to my file
>> system. 'settrans -a subhurd /hurd/ext2fs /dev/hd1' works on my
>> system.
> Have you put a filesystem on /dev/hd1 without partitioning it? That's
> certainly unusual... But if it is so, I guess that's not the reason for
> the failure.
I have used fdisk to create only one partition on that disk. I tried to create
/dev/hd1s1, but it doesn't work.
>> antrik, have you used my modified subhurd? I wanted to try samuel's
>> patch and see whether the patch can fix the bug in the modified
>> subhurd (subhurd sometimes hangs). Can you try that for me if you have
>> the time and if you have my modified subhurd?
> Unfortunately, I don't have either right now...
I finally got a working subhurd and I tested my modified subhurd with samuel's
patch to auth. It seems working. I run subhurd for so many times, but didn't see
subhurd hang in login. But it does hang somewhere else. Maybe there are some
other bugs in subhurd. I wonder if it's because the proc server in subhurd
cannot run in a higher priority. I need more test.

Zheng Da

reply via email to

[Prev in Thread] Current Thread [Next in Thread]