bug-hurd
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [PATCH 1 of 3] switch license to GPLv3 so we can include files under


From: Arne Babenhauserheide
Subject: Re: [PATCH 1 of 3] switch license to GPLv3 so we can include files under Apache 2.0. For details, see: http://www.apache.org/licenses/GPL-compatibility.html
Date: Mon, 11 Apr 2011 23:09:36 +0200
User-agent: Wanderlust/2.14.1 (Bad Medicine-pre) SEMI/1.14.6 (Maruoka) FLIM/1.14.9 (Goj┼Ź) APEL/10.8 Emacs/23.3 (x86_64-pc-linux-gnu) MULE/6.0 (HANACHIRUSATO)

At Fri, 8 Apr 2011 21:11:01 +0200,
Hi, 
<olafBuddenhagen@gmx.net> wrote:
> > switch license to GPLv3 so we can include files under Apache 2.0. For 
> > details, see: http://www.apache.org/licenses/GPL-compatibility.html
> 
> That's way to long for a Patch title. Move the second sentence to the
> body of the commit message please.

Adapted. I'll send a second patch series with the updated patches.

> > -      license = 'GNU GPL2',
> > +      license = 'GNU GPL3',
> 
> Is this really the only place where the license is stated? If so, it
> needs fixing -- every source file should state the license in the
> header...

It should suffice to state the project license. The source files are GPLv2 or 
later, so they can be used under GPLv3. 

The project as a whole can only be under GPLv3, though. 

I missed out changing COPYING - adapted now.



reply via email to

[Prev in Thread] Current Thread [Next in Thread]