[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: trying to build gnumach.gz

From: Andrew Engelbrecht
Subject: Re: trying to build gnumach.gz
Date: Mon, 01 Aug 2011 17:45:52 -0400
User-agent: Roundcube Webmail/0.5.2

On Mon, 1 Aug 2011 21:56:35 +0200, Samuel Thibault wrote:
Are you building on some x86_64 linux?

Yes, 64bit Fedora.

In that case it's deemed to fail since linux will try to build gnumach
is 64bit mode. You need to cross-compile:

I did configure using the --host=i386 flag, but I'll do it your way. ;)

install a 32bit version of mig, and use this for configure:

CPP='gcc -m32 -E -x c -undef -ansi' CC='gcc -m32' LD='ld -melf_i386'
./configure --host=i686-unknown-linux-gnu

Of course configure could be made to do this by itself, but the 32bit
mig installation is still mandatory.

Now I'll make a record of what I've tried:

cd gnumach
autoreconf --install

cd ../mig
autoreconf --install

cd ../gnumach-build
./gnumach/configure --prefix= --host=i686-unknown-linux-gnu
make DESTDIR=~/gnu install-data

cd ../mig-build
TARGET_CPPFLAGS=-I"$GNU"/include ../mig/configure --prefix="$GNU" --host=i686-unknown-linux-gnu
make all install

cd ../gnumach-build
CPP='gcc -m32 -E -x c -undef -ansi' CC='gcc -m32' LD='ld -melf_i386' ./gnumach/configure --host=i686-unknown-linux-gnu

Then I installed glibc-devel.i686 and ./configure stopped complaining about a non-functioning "gcc -m32".

Now I get a weird error when I run "make gnumach.gz":

gawk -f ../gnumach/gensym.awk ../gnumach/i386/i386/i386asm.sym > i386/i386/i386asm.symc gcc -m32 -DHAVE_CONFIG_H -I. -I../gnumach -nostdinc -imacros config.h -Ii386 -I. -I../gnumach/i386 -I../gnumach/i386/include/mach/sa -I../gnumach/include -Wall -fno-strict-aliasing -fno-stack-protector -g -O2 -S -x c -o i386/i386/i386asm.symc.o i386/i386/i386asm.symc
In file included from ../gnumach/kern/thread.h:44:0,
                 from i386/i386/i386asm.symc:2:
./gnumach/kern/ast.h:45:25: fatal error: machine/ast.h: No such file or directory
compilation terminated.

Hm, There is no "machine" directory in the repo. I'm still pretty much a noob, so I'm not sure how to debug this.

Thanks again for the help.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]