[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

My failure to install Hurd on Debian GNU/Linux kvm

From: Thomas Schmitt
Subject: My failure to install Hurd on Debian GNU/Linux kvm
Date: Sat, 20 Aug 2011 15:11:24 +0200


I Samuel Thibault's thread 'cdrom interface?' i wrote:
> > Well, i am a bit embarassed that i failed to get Debian/Hurd running
> > on qemu-kvm of a Debian/Linux squeeze. It installs but then does not
> > boot. Other things kept me from re-trying and then asking for help.

Samuel Thibault wrote:
> Don't hesitate to ask. I'm running it completely fine in qemu-kvm in
> wheezy.

Ok, here is my mail sketch of end of june 2011. I have been distracted
from this topic since then. But at least i now verified that kvm still
starts from the Hurd "disk" into a GRUB prompt. (Over X and ssh from the
headless Debian GNU/Linux to my workstation. My todo list says that i
shall look for a non-graphical mode where i can copy+paste and need no X.)

29 June 2011:

I have a freshly installed Debian GNU/Linux 6.0.2 on amd64.
Now i try to install Hurd according to

$ kvm-img create hurd-install.qemu 3G
Formatting 'hurd-install.qemu', fmt=raw size=3221225472 
$ kvm -m 512 -net nic,model=ne2k_pci -net user -no-kvm-irqchip -hda 
hurd-install.qemu -cdrom netinst.iso -boot d

I have chosen to use the entire "disk".
This worked so far (except minor problems) until the install software
urges me to remove the CD and to boot.
Well, i do not know how to remove the virtual CD. So the reboot ends
up in the first installer menu.
This menu has an option to boot from the first disk.
I did, but this only yields a GRUB prompt.

Very strangely, next day, after rebooting the hosting GNU/Linux, i get from
  $ kvm -m 512 -net nic,model=ne2k_pci -net user -hda hurd-install.qemu 
  kvm: invalid option -- '-no-kvirqchip'
I can still see the successful kvm runs of yesterday with that option
(SSH session from not rebooted workstation).
This was the first reboot after  apt-get install qemu-kvm .
Without that option i get to the GRUB prompt again.

>From the description i understand that it is not really needed
for the installed Linux kernel:
  $ uname -a
  Linux debian2 2.6.32-5-amd64 #1 SMP Tue Jun 14 09:42:28 UTC 2011 x86_64 

The virtual hard disk now has this layout:
  $ /sbin/fdisk -lu  hurd-install.qemu
  [... nagging about cylinder alignment ...]
              Device Boot   Start       End     Blocks   Id  System
  hurd-install.qemu1   *     2048   5926911    2962432   83  Linux
  hurd-install.qemu2      5928958   6289407     180225    5  Extended
  hurd-install.qemu5      5928960   6289407     180224   82  Linux swap / 

Any idea how to get a running system ?

Before installation i successfully tried the example from
$ wget http://people.debian.org/~sthibault/hurd-i386/debian-hurd.img.tar.gz
$ tar -xz < debian-hurd.img.tar.gz
$ qemu -net nic,model=rtl8139 -net user /dvdbuffer/debian-hurd-20110323.img
But i want a permanently installed Hurd by which i can explore the
possibility to send SCSI commands to CD drives.

Minor problems:

The installation instructions propose to run kvm as normal user.
On the freshly installed Debian 6.0.2, the permissions of /dev/kvm
do not allow this. One ends up without hardware virtualiziation,
which is indeed very slow.

$ kvm -m 512 -net nic,model=ne2k_pci -net user -no-kvm-irqchip -hda 
hurd-install.qemu -cdrom netinst.iso -boot d
open /dev/kvm: Permission denied
Could not initialize KVM, will disable KVM support

I solved this by adding my normal user id to group kvm.
Then i aborted the install run, deleted the disk image and started
installation from scratch. (I.e. by kvm-img create hurd-install.qemu 3G)


The install process gave me no opportunity to enter the prescibed
network paramters. (IP address: , ...)
Is this a bad sign ?


Have a nice day :)


reply via email to

[Prev in Thread] Current Thread [Next in Thread]