[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [PATCH] simplify ulimit implementation

From: Pino Toscano
Subject: Re: [PATCH] simplify ulimit implementation
Date: Mon, 19 Nov 2012 18:49:02 +0100
User-agent: KMail/1.13.7 (Linux/3.2.0-3-amd64; KDE/4.8.4; x86_64; ; )

Alle lunedì 19 novembre 2012, Roland McGrath ha scritto:
> sysdeps/posix is appropriate because it's implemented in terms of
> POSIX interfaces.


> It's bad to lose any functionality, though __UL_GETMAXBRK actually
> being used seems a bit unlikely.  But it's easy enough to add it. 

Please note that in the linux implementation that case has not bee 
implemented on purpose: in d2f5be2a1235061b46c51d7530264d086eca46ef that 
implementation was copied from the bsd one, and the case for 3 
(__UL_GETMAXBRK) removed (with the comment adjusted).

If __UL_GETMAXBRK is really wanted, I could propose to implement it in 
the new posix version, but surrounded within a #ifndef 
ULIMIT_SKIP___UL_GETMAXBRK (or better names welcome), and then replace 
the whole linux implementation with:
#include <sysdeps/posix/ulimit.c>
(my initial idea was something close to the way e.g. the linux sysconf 
implementation "overrides" the posix one, but the fact that ulimit takes 
varargs complicates that approach a bit.)

> So I'd do: First commit: move file verbatim to sysdeps/posix/.
> Second commit: add __UL_GETMAXBRK to that implementation.
> Third commit: remove sysdeps/unix/bsd/ file.

OK, I will split the commits once approved.

Pino Toscano

Attachment: signature.asc
Description: This is a digitally signed message part.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]