[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: problem on shut-down

From: Riccardo Mottola
Subject: Re: problem on shut-down
Date: Fri, 04 Apr 2014 15:29:06 +0200
User-agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:28.0) Gecko/20100101 Firefox/28.0 SeaMonkey/2.25


Justus Winter wrote:
>it's not inetd. It actually stops here:
>root@ithil:~# ps -x
Please use ps -Ax:

root@pluto ~ # ps -x|wc --lines
root@pluto ~ # ps -Ax|wc --lines
I'll do next time :) I actually used ps -x just to look what init.d process was being run with "stop".
>11434  - Sow   0:00.04 startpar -p 4 -t 20 -T 3 -M stop -P 2 -R 0
>11451  - Sow   0:00.05 /bin/sh /etc/init.d/sendsigs stop
>11454  - So    0:00.02 sync
>11455 p0 Sw    0:00.57 su -
>11457 p0 Sw    0:00.62 -su
>11463 p0 S     0:00.03 ps -x
>"sendisgs stop"
sendsigs uses killall5 which has been proven to be problematic.  In
short it does something like 'pkill -SIGSTOP . ; pkill -SIGXXX .'.
This is problematic for a multiserver OS like Hurd, because stopping
vital system servers will most likely also prevent killall5 from
completing its job (e.g. killall5 used to stop procfs and then it
tried to iterate over /proc, resulting in a deadlock).
Do we have a precedence problem here?
To prevent this, I came up with
5f536bc5ae7948555af12b105a97aa887fe5da48 ff.  I trust you are running
the stock Debian/Hurd package?
I am running stock debian stuff, yes.

>I shut down from console and had a remote connection open. At this point
>even issuing a "sync" will hang and I need to cut the machine's power
Please be more specific when reporting this, as ideally I should be
able to reproduce your problem.

I*guess*  that you meant to say: If you do not log in using telnet,
your system shuts down fine, but if you do and then shut your system
down, it hangs.  Is that correct?
Actully, I wasn't implying that the hang is dependent on the open telnet connection. I just said I launched shutdown and watched the progress on the open telnet connection because it is easier and I can check it, copy&paste stuff, etc.
With a single console (I don't get multiple consoles) it is a bit awkward.

I don't know yet a minimum set of action that reproduces the hang.

I know that if I power on, login, shut down all on the local console, the cycle ends with success.

If on the other and I run apt-get, do some compiling and use the box, it hangs on shutdown. It hangs even if there is no open telnet connection!

Sometimes bugs can't be easily reproduced, sadly. One needs to gather information in the best possible way then...


reply via email to

[Prev in Thread] Current Thread [Next in Thread]