[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Debian/Hurd: Console Timeout Error

From: Charlie Sale
Subject: Re: Debian/Hurd: Console Timeout Error
Date: Sun, 8 Apr 2018 14:33:45 -0400

I tried doing that, but I got some errors during the process. Here is what I did:

1. $ fdisk -l debian-hurd*.img
Device                    Boot   Start      End Sectors  Size Id Type
debian-hurd-20171101.img1         2048  1953791 1951744  953M 82 Linux swap / Solaris
debian-hurd-20171101.img2      1955838 10239999 8284162    4G  5 Extended
debian-hurd-20171101.img5      1955840 10239999 8284160    4G 83 Linux

2. # losetup -o 1955838 /dev/loop0 debian-hurd-20171101.img
Which worked fine.

3. e2fsck -y /dev/loop0

e2fsck 1.43.5 (04-Aug-2017)
ext2fs_open2: Bad magic number in super-block
e2fsck: Superblock invalid, trying backup blocks...
e2fsck: Bad magic number in super-block while trying to open /dev/loop0

The superblock could not be read or does not describe a valid ext2/ext3/ext4
filesystem.  If the device is valid and it really contains an ext2/ext3/ext4
filesystem (and not swap or ufs or something else), then the superblock
is corrupt, and you might try running e2fsck with an alternate superblock:
   e2fsck -b 8193 <device>
   e2fsck -b 32768 <device>

I tried doing both of the suggested remedy commands, but neither worked. They just
returned the same output.

Because these commands failed, nothing changed in booting my Debian.

Thanks for trying to help. Any more suggestions?


On Sun, Apr 8, 2018, 11:27 AM Svante Signell <svante.signell@gmail.com> wrote:
On Sun, 2018-04-08 at 10:46 -0400, Charlie Sale wrote:
> The other major issues is that fsck fails during the boot. I don't
> know if this is as important as the console failure, but I thought I
> would point it out.

Hi Charlie,

You should check your image from your Linux host:
NOTE: Check the offset for your / partition
fdisk -l debian-hurd-20171101.img
2048*512 = 1048576
/sbin/losetup -o 1048576 /dev/loop0 debian-hurd-20171101.img
e2fsck -y /dev/loop0
losetup -d /dev/loop0

After that I think your image will boot fine. 

reply via email to

[Prev in Thread] Current Thread [Next in Thread]