[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: libdiskfs assertion failed

From: Joshua Branson
Subject: Re: libdiskfs assertion failed
Date: Fri, 26 May 2023 11:02:44 -0400
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/27.1 (gnu)

Samuel Thibault <samuel.thibault@gnu.org> writes:

> Hello,
> Joshua Branson, le jeu. 25 mai 2023 22:32:24 -0400, a ecrit:
>> So I updated my T43 to the bleeding edge Debian in real hardware, which
>> come on that is pretty cool!  The update process was pretty easy.  I
>> will describe that in the postscript.  I did get this error recently
>> when I shutdown the Hurd:
>> extfs: ../../libdiskfs/disk-pager.c:107: fault_handler: Assertion
>> 'scp->sc_error = 10' failed.
> Mmm, perhaps you can make it print the scp->sc_error value so we get an
> idea of what that is?

I am definitely game to help you figure out what that is, because it
seems to be happening everytime I turn off this machine.  It does not
seem to be a massively terrible bug, but it is there.  How would I go
about printing that scp->sc_error value?

I am running this in machine in real hardware.  I get that error message
after I run "sudo poweroff".  I see that error message right before the
Hurd gets halted.  I imagine I need to turn on the kernel debugger to
print that value.

>> #+BEGIN_SRC shell
>> wget
>> http://ftp.de.debian.org/debian/pool/main/d/debian-ports-archive-keyring/debian-ports-archive-keyring_2023.02.01_all.deb
>> #+END_SRC
> Rather use https
>> apt-get update
>> apt-get dist-upgrade
>> #+END_SRC
>> The "apt-get dist-upgrade" command did fail for me.
> How did it fail?

I wish I had written it down.  It downloaded all the packages, then
tried to update gnumach, then that failed and it said that I needed to
upgrade gnumach, reboot, update libc, then upgrade the Hurd.  Or
something like that.

It said something about hurd-dev package depending on libc, which needed
to be a later version.  It was pretty sly of apt to tell me to run
"apt --fix-broken install", because that just worked.
> The Debian release notes recommend to run
> apt upgrade --without-new-pkgs
> before apt dist-upgrade

good to know!  sounds like I need to update the qemu page that shows how
to use the rumpkernel again...

> Samuel


Joshua Branson
Sent from the Hurd

reply via email to

[Prev in Thread] Current Thread [Next in Thread]