[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

SOLVED WAS [Re: [Guix] netdde setup confusion]

From: Janneke Nieuwenhuizen
Subject: SOLVED WAS [Re: [Guix] netdde setup confusion]
Date: Fri, 26 May 2023 19:46:44 +0200
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/28.2 (gnu/linux)

Sergey Bugaev writes:

Hi Sergey,

> On Fri, May 26, 2023 at 8:19 PM Janneke Nieuwenhuizen <janneke@gnu.org> wrote:
>> Hi!
> Hi,
>> I'm trying to get netdde to work in Guix without much success.


>> /hurd/pfinet: file_name_lookup eth0: No such file or directory
> See, you're telling it to open "eth0", which is not a thing. /dev/eth0
> (which you are setting up yourself just a few lines above) is. So pass
> --interface=/dev/eth0 instead of --interface=eth0.
> This is different from Linux, where (apparently) network interfaces
> exist in their own little namespace and not in the file system.
> On Debian, "/dev/eth0" is configured in /etc/network/interfaces, and
> then 'ifup -a' brings it up automatically. So the issue is not with
> your build of netdde, it's with how pfinet gets configured.

That's it!  How simple, changing it to /dev/eth0 works!!!

(It's a bit weird that when using gnumach's builtin networking using
eth0 or dev/eth0 was inconsequential).

Thank you!

Now to re-attempt installing Guix/Hurd on my Thinkpad X60 (yes, I know,
we need to look at 64bit ;-)


Janneke Nieuwenhuizen <janneke@gnu.org>  | GNU LilyPond https://LilyPond.org
Freelance IT https://www.JoyOfSource.com | Avatar® https://AvatarAcademy.com

reply via email to

[Prev in Thread] Current Thread [Next in Thread]