[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Starting a subhurd

From: Ravin Perera
Subject: Re: Starting a subhurd
Date: Fri, 3 Nov 2023 07:07:49 +0530

Hi Samuel,

Your suggested methods and fixes worked like a charm. Looking back at things, you are correct. The documentation does seem up to date. Maybe we can also include a small note about the pager bug and the size limit of Hurd (which comes up when downloading the img) to help new users even more. Thank you for taking the time to prepare a detailed explanation regarding my issue, appreciate it a lot. Will come back for help if I need it (hopefully I won't). Thanks again.

Best Regards,

On Fri, Nov 3, 2023 at 1:20 AM Samuel Thibault <samuel.thibault@gnu.org> wrote:

Ravin Perera, le jeu. 02 nov. 2023 19:58:40 +0530, a ecrit:
> The documentation seems to be a bit old and outdated,

I don't think it (https://www.gnu.org/software/hurd/hurd/subhurd.html)
is old/outdated, as far as I can tell it is providing the proper

> are there any relevant resources I can use?

That page is what is most relevant, by providing examples.

> Up until now, I've mounted a hurd img using -hdb to my qemu
> system and modified the fstab in the image file as follows
> ([1]https://imgbox.com/CxspjJ7L). I didn't edit the boot script
> because I couldn't figure out what to edit.

There is nothing to edit.

> Then I made the hd1s2 partition readonly  (mounted to /mnt using
> `settrans -a /mnt /hurd/ext2fs /dev/hd1s2` and then used fsysopts
> to make readonly) and tried booting the subhurd using `boot -D /mnt
> --boot-script=/mnt/boot/servers.boot /dev/hd1s2`

Why using --boot-script? The wiki page does not talk about it. On my
system things go alright without that option. And thus -D is not useful,
and mounting the image neither. Apparently your issue comes from the "-T
typed" part of that bootscript, which doesn't match the "pseudo-root"
parameter, which is not a typed string.

So either fix servers.boot to use -T device, or much better, just let
boot use its default script which is all fine:

boot /dev/hd1s2

That being said, you will probably get a crash from mach-defpager (most
probably because there is already a default pager), which takes the
subhurd down. You can comment that out from /etc/hurd/runsystem.sysv

That is rather a bug to fix, not a documentation issues.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]