[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

wrong library path on cross compiling - libtool 1.5

From: Sebastian Mancke
Subject: wrong library path on cross compiling - libtool 1.5
Date: Mon, 14 Jul 2003 22:36:03 +0200
User-agent: KMail/1.4.3


I hope, my explanation ist enough.

On cross compiling kaffe (www.kaffe.org) to arm-linux
I ran in tho following error.

>  It inherently uses /usr/lib/libjpeg.so instead of 
> /usr/arm-linux/lib/libjpeg.so
> I also tryed to set the lib dirs by the following options:
>       LDFLAGS=-L/usr/arm-linux/lib/ 
>       --with-libraries=/usr/arm-linux/lib/
>       --with-awtlibpath=/usr/arm-linux/lib/
> Theese had no affects.

On kaffe Mailing list I got the following answer:
That's yet another bug in libtool, AFAIK. It seems to pick up libraries passed
by --with-libraries only after it has tried to find a library in common 
library locations like /usr/lib. See
http://mail.gnu.org/archive/html/libtool/2001-10/msg00127.html for a possible
patch, that apparently has a typo somewhere ... sigh.

Kind regards,
  Sebastian Mancke

reply via email to

[Prev in Thread] Current Thread [Next in Thread]