[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

build bugs

From: Ralf Wildenhues
Subject: build bugs
Date: Sun, 25 Jan 2004 12:23:04 +0100
User-agent: Mutt/

Hi there,

Trying to build libtool from CVS head I run into several problems,
some of which seem to be related to bash/ksh assumptions.  Following
is the first I tried to analyze (others might follow):

CVS Autoconf, Automake and libtool 1.1385 2004/01/22 22:25:42) 1.5a
on a Debian testing (gcc-3.3.2, GNU make 3.80, GNU sed 4.0.7,
/bin/sh is a dash 0.4.19), i686.

Description of problem:
after building with
$ CONFIG_SHELL=/bin/bash ./bootstrap; [...]
this suceeds:
$ make check VERBOSE=X TESTS="demo-conf.test demo-make.test"
but this fails:
$ make check VERBOSE=X TESTS="demo-conf.test demo-make.test" 
| creating .libs/helldlS.c
| extracting global C symbols from `./.libs/libhello.a'
| (cd .libs && gcc -c -fno-builtin "helldlS.c")
| helldlS.c:12: error: stray '\1' in program

More problems show up when configuring with dash alone, this one I
could boil down to the following:  bash and ash handle the attached
snippet from `libtool' wrongly, creating weird characters in the
output, outputs from
$ $SHELL -x b > $SHELL_output 2>&1

This affects files like config.status and others as well, obviously.

After checking Debian bug archives, libtool ML archives, I did not
find this bug reported.  If you think this is a bug in dash, then
let me know, so I can file a bug against dash.


Attachment: b
Description: Text document

Attachment: dash_output
Description: Text document

Attachment: bash_output
Description: Text document

reply via email to

[Prev in Thread] Current Thread [Next in Thread]