[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

missing destdir with OpenBSD-3.5

From: Han Boetes
Subject: missing destdir with OpenBSD-3.5
Date: Sun, 11 Apr 2004 21:47:06 +0200
User-agent: Mutt/1.5.6i


While building glib2 on OpenBSD I ran into this error while doing a

Making install in gobject
make  install-am
/bin/sh ../mkinstalldirs /usr/pkgmk/work/glib2/pkg/usr/local/lib
 /bin/sh ../libtool --mode=install /usr/bin/install -c  libgobject-2.0.la 
libtool: install: warning: relinking `libgobject-2.0.la'
(cd /usr/pkgmk/work/glib2/src/glib-2.4.0/gobject; /bin/sh ../libtool  
--mode=relink egcc -O2 -march=i686 -pipe -Wall -o libgobject-2.0.la -rpath 
/usr/local/lib -version-info 400:0:400 -export-dynamic gboxed.lo gclosure.lo 
genums.lo gobject.lo gparam.lo gparamspecs.lo gsignal.lo gsourceclosure.lo 
gtype.lo gtypemodule.lo gtypeplugin.lo gvalue.lo gvaluearray.lo 
gvaluetransform.lo gvaluetypes.lo ../glib/libglib-2.0.la -lintl 
-inst-prefix-dir /usr/pkgmk/work/glib2/pkg)
libtool: link: warning: 
seems to be moved
egcc -shared  -fPIC -DPIC -o .libs/libgobject-2.0.so.400.0  .libs/gboxed.o 
.libs/gclosure.o .libs/genums.o .libs/gobject.o .libs/gparam.o 
.libs/gparamspecs.o .libs/gsignal.o .libs/gsourceclosure.o .libs/gtype.o 
.libs/gtypemodule.o .libs/gtypeplugin.o .libs/gvalue.o .libs/gvaluearray.o 
.libs/gvaluetransform.o .libs/gvaluetypes.o  -L/usr/local/lib 
/usr/local/lib/libglib-2.0.so.400.0 /usr/local/lib/libintl.so.1.1  -march=i686
egcc: /usr/local/lib/libglib-2.0.so.400.0: No such file or directory
libtool: install: error: relink `libgobject-2.0.la' with the above command 
before installing it
*** Error code 1

Stop in /usr/pkgmk/work/glib2/src/glib-2.4.0/gobject (line 470 of Makefile).
*** Error code 1

Stop in /usr/pkgmk/work/glib2/src/glib-2.4.0/gobject (line 755 of Makefile).
*** Error code 1

Stop in /usr/pkgmk/work/glib2/src/glib-2.4.0/gobject (line 749 of Makefile).
*** Error code 1

Stop in /usr/pkgmk/work/glib2/src/glib-2.4.0 (line 452 of Makefile).
*** Error code 1

Stop in /usr/pkgmk/work/glib2/src/glib-2.4.0 (line 690 of Makefile).

Obviously the `destdir' is missing from the cc line; changing the command

egcc -shared -fPIC -DPIC -o .libs/libgobject-2.0.so.400.0 .libs/gboxed.o 
.libs/gclosure.o .libs/genums.o .libs/gobject.o .libs/gparam.o 
.libs/gparamspecs.o .libs/gsignal.o .libs/gsourceclosure.o .libs/gtype.o 
.libs/gtypemodule.o .libs/gtypeplugin.o .libs/gvalue.o .libs/gvaluearray.o 
.libs/gvaluetransform.o .libs/gvaluetypes.o -L/usr/local/lib 
/usr/local/lib/libintl.so.1.1 -march=i686

And that worked like expected.

This problem occurs with other gnu-software like gettext as well.

Please change libtool so it will support fakeinstalls for OpenBSD.

# Han
 _/| VK                                                        |\_
// o\   All syllogisms have three parts; therefore this is    /o \\
|| ._)                   not a syllogism.                    (_. ||
//__\                                                         /__\\
)___(                                                         )___(

reply via email to

[Prev in Thread] Current Thread [Next in Thread]