[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

gcc bootstrapping problem

From: Post, Mark K
Subject: gcc bootstrapping problem
Date: Sat, 18 Sep 2004 12:41:20 -0400


I'm trying to create a native 64-bit compiler for Slack/390.  I downloaded
some existing ones from the Fedora project to get me started.  I ran into a
problem with them.  That is, far, far along into the build, the make process
starts to configure in the s390x-slackware-linux/libjava/ directory, and it
invokes ltconfig.  The ltconfig script issues this command, and gets the
error shown:
ltconfig:1487:  /tmp/build-gcc-3.3.4-s390x-1/gcc.build.lnx/gcc/xgcc
-shared-libgcc -B/tmp/build-gcc-3.3.4-s390x-1/gcc.build.lnx/gcc/ -nostdinc++
-v3/src/.libs -B/usr/s390x-slackware-linux/bin/
-B/usr/s390x-slackware-linux/lib/ -isystem
/usr/s390x-slackware-linux/include -o conftest -g -O2 -D_GNU_SOURCE
-fno-builtin -fno-rtti -fno-exceptions   conftest.cc conftstm.o 1>&5
conftstm.o(.eh_frame+0x11): In function `main':
ftest.cc:9: undefined reference to `__gxx_personality_v0'
collect2: ld returned 1 exit status

According to a conversation I had with a gcc developer, the issue is
"ltconfig is
attempting to use the C driver (xgcc) to build and link a C++ program; this
is the reason of the failure."

I'm using libtool 1.5.6 on this system.  I tried searching for prior bug
reports, but didn't come across any.  It was pretty late at night, though,
and I could have missed one.

If this is a known issue, I'll upgrade to the latest released version.  If
not, please tell me what other information you need from me to help debug


Mark Post

reply via email to

[Prev in Thread] Current Thread [Next in Thread]