[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: bug or what??

From: Ralf Wildenhues
Subject: Re: bug or what??
Date: Mon, 1 Aug 2005 17:39:26 +0200
User-agent: Mutt/1.4.1i

Hi Tuomas,

Sorry for the late reply.

* Hyvärinen Tuomas wrote on Wed, Jul 13, 2005 at 06:23:10AM CEST:
> I have tried to search information about my problem but with no luck so I'm
> stuck!! I'm trying to install usbobex/openobex to my fedora core 3 and also
> FC4 because I want to download pictures from my nokia 6630. I have now FC4
> and FC3 with allupdated. someone was thinking that it is connected to
> automake and aclocal so I have tried to create softlink from automake to
> automake-1.4 and from aclocal to aclocal-1.4 but nothing happens. I really
> hope that you can help because I don't know where to ask anymore!?! 
> I now that it is that line libtool --tag=cc but then what!?! I have really
> tried to solve this out but my skills are not good enough :(

> address@hidden lib]# make install
> Making install in m4macros
> make[1]: Entering directory `/root/openobex/lib/m4macros'
> make[2]: Entering directory `/root/openobex/lib/m4macros'
> make[2]: Nothing to be done for `install-exec-am'.
> test -z "/root/usbobex/share/aclocal" || mkdir -p -- 
> "/root/usbobex/share/aclocal"
> /usr/bin/install -c -m 644 'openobex.m4' 
> '/root/usbobex/share/aclocal/openobex.m4'
> make[2]: Leaving directory `/root/openobex/lib/m4macros'
> make[1]: Leaving directory `/root/openobex/lib/m4macros'
> Making install in src
> make[1]: Entering directory `/root/openobex/lib/src'
> if /bin/sh ../libtool --tag=CC --mode=compile gcc -DHAVE_CONFIG_H -I. -I. 
> -I.. -I../src    -O2 -MT obex.lo -MD -MP -MF ".deps/obex.Tpo" -c -o obex.lo 
> obex.c; \
> then mv -f ".deps/obex.Tpo" ".deps/obex.Plo"; else rm -f ".deps/obex.Tpo"; 
> exit 1; fi
> libtool: unrecognized option `--tag=CC'

Side question: Did you not run `make' before running `make install'?
Installation should not cause recompilation (but it may cause relinking
at times).

The problem is connected to automake/libtool version dependencies.
Packages libtoolized with version <1.5 create `libtool' scripts which do
not understand the --tag option, new automaken however create rules
which contain the tag option.

Methinks you did not re-run the autotools before building.  They are
usually called from a script called `bootstrap' or similar, within the
top level source directory.  Then rerun configure, make, and make

If usbobex is an actively maintained project, you should ask the
maintainer to use up-to-date autotools with the tarballs he distributes.
That way you should not have to deal with any of the yourself at all.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]