[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Libtool problems with 1.5.18

From: Ralf Wildenhues
Subject: Re: Libtool problems with 1.5.18
Date: Sun, 21 Aug 2005 11:45:10 +0200
User-agent: Mutt/1.5.9i

Hi Shreyas,

* Shreyas Sriniavasan wrote on Sun, Aug 21, 2005 at 09:59:46AM CEST:
> I have a build of evolution which requires a version of libsoup.  
> Initially i had libsoup installed in /opt/gnome/ and later moved it  
> to /sw. When i did so i ran a make distclean and re configure before  
> i installed to a new prefix.
> But while building evolution i see that libtool still searches for  
> libsoup in the old prefix. And i get the following error
> libtool: link: warning: `/sw/lib/libbonobo-activation.la' seems to be  

Yes, that is because libtool records both the installation path and the
paths of dependent libraries.  This is so that linking against them will
work even if the linker would not otherwise find the libraries on its

Surely, this advantage also causes disadvantes: libraries cannot be
moved around at will in the system.  Within paths searched automatically
by the runtime linker this is somewhat mitigated (/etc/ld.so.conf for
GNU/Linux e.g.) and Libtool does not add rpath entries then, but still
you will have trouble moving libraries around in the system.

Moving installed libraries around is not possible on some systems at
all.  I agree that it is unfortunate that current Libtool enforces this
restriction also on systems which do not exhibit this limitation in
general.  However, a solution to this problem requires a bit of work
(which is not yet done, unfortunately), because several issues are
connected with this.  I can point out discussions on libtool lists about

> This breaks my build :(. Clearly libtool should not be looking at the  
> old path. I have tried numerous things suggested by online forums but  
> havent been able to solve this issue. Is there a patch for the same ?
> or any other solution other that is feasible.

The clean way, with current Libtool, would be to reinstall the
dependence libraries.  You may use DESTDIR to install them temporarily
to a staging area.

> p.s: I already tries removing and re installing libtool as suggested  
> by a online forum

No, that does not help at all.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]