[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Libtoool 2.2.6a make check error

From: Ralf Wildenhues
Subject: Re: Libtoool 2.2.6a make check error
Date: Wed, 1 Oct 2008 20:49:36 +0200
User-agent: Mutt/1.5.18 (2008-05-17)

Hello Nick,

Thanks for the report.

* N.W. England wrote on Tue, Sep 30, 2008 at 05:05:49PM CEST:
> I have had problems where libtool was linking to a 32bit library while I 
> am on a 64bit machine so I tried updating to the latest libtool. I 
> downloaded the 2.2.6a version from GNU FTP mirror.
> FAIL: tests/fcdemo-exec.test
> PASS: tests/fcdemo-conf.test
> PASS: tests/fcdemo-make.test
> FAIL: tests/fcdemo-exec.test
> PASS: tests/fcdemo-shared.test
> PASS: tests/fcdemo-make.test
> FAIL: tests/fcdemo-exec.test
> (the error while trying to compile other software is:)
> /lib/libstdc++.so: could not read symbols: File in wrong format
> collect2: ld returned 1 exit status

I suppose that error persisted when you used the latest libtool?
(It's not clear to me from the report which version you used first,
and whether you re-tried with current libtool).

Anyway, for the test failures please post the output of
  ./libtool --tag=FC --config
  env TESTS="tests/fcdemo-static.test tests/fcdemo-make.test \
             tests/fcdemo-exec.test tests/fcdemo-conf.test \
             tests/fcdemo-make.test tests/fcdemo-exec.test \
             tests/fcdemo-shared.test tests/fcdemo-make.test \
             tests/fcdemo-exec.test"  make -e check VERBOSE=yes

Also, it would be good to know what system you're using, what
distribution if any (including version), and the output of
  ls -ld /lib* /usr/lib*


reply via email to

[Prev in Thread] Current Thread [Next in Thread]