[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Libtoool 2.2.6a make check error

From: N.W. England
Subject: Re: Libtoool 2.2.6a make check error
Date: 02 Oct 2008 16:03:22 +0100


Attached is the output of ./libtool --tag=FC --config (out.log) and with the tests (out2.log)

ls -ld /lib* /usr/lib* gives:
drwxr-xr-x  8 root root  4096 2008-05-14 10:33 /lib
drwxr-xr-x  5 root root  4096 2008-06-12 12:03 /lib64
drwxr-xr-x 54 root root 28672 2008-09-08 14:32 /usr/lib
drwxr-xr-x 77 root root 69632 2008-09-15 09:18 /usr/lib64

I am running on a 64 bit SUSE system 10.2
Distributor ID: SUSE LINUX
Description:    openSUSE 10.2 (X86-64)
Release:        10.2

I also have libraries installed /home/<username>/custom/lib and /home/<username>/custom/lib64 which are on the LD_LIBRARY_PATH (since I do not have root access on this machine)

The error did indeed persist with the new libtool (which other than failing unit tests seems to work exactly the same as the previous version,(GNU libtool 1.5.22 1.1220.2.365 2005/12/18 22:14:06)

If I "hid" the files in /home/<username>/custom/lib then libtool correctly linked against the ones in /lib64 and if I moved the files back then ran the program it works (mostly, although I am having a problem where python isn't looking in the right place and complaining about /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.9' not found since its not checking /home/<username>/custom/lib64 even though its on the LD_LIBRARY_PATH)

I hope I have provided all the information you asked for!

Many thanks,


On Oct 1 2008, Ralf Wildenhues wrote:

Hello Nick,

Thanks for the report.

* N.W. England wrote on Tue, Sep 30, 2008 at 05:05:49PM CEST:
I have had problems where libtool was linking to a 32bit library while I am on a 64bit machine so I tried updating to the latest libtool. I downloaded the 2.2.6a version from GNU FTP mirror.
FAIL: tests/fcdemo-exec.test
PASS: tests/fcdemo-conf.test
PASS: tests/fcdemo-make.test
FAIL: tests/fcdemo-exec.test
PASS: tests/fcdemo-shared.test
PASS: tests/fcdemo-make.test
FAIL: tests/fcdemo-exec.test
(the error while trying to compile other software is:)

/lib/libstdc++.so: could not read symbols: File in wrong format
collect2: ld returned 1 exit status

I suppose that error persisted when you used the latest libtool?
(It's not clear to me from the report which version you used first,
and whether you re-tried with current libtool).

Anyway, for the test failures please post the output of
 ./libtool --tag=FC --config
 env TESTS="tests/fcdemo-static.test tests/fcdemo-make.test \
            tests/fcdemo-exec.test tests/fcdemo-conf.test \
            tests/fcdemo-make.test tests/fcdemo-exec.test \
            tests/fcdemo-shared.test tests/fcdemo-make.test \
            tests/fcdemo-exec.test"  make -e check VERBOSE=yes

Also, it would be good to know what system you're using, what
distribution if any (including version), and the output of
 ls -ld /lib* /usr/lib*


Attachment: out.log
Description: out.log

Attachment: out2.log
Description: out2.log

reply via email to

[Prev in Thread] Current Thread [Next in Thread]