[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [libtool 2.2.6] testsuite: 33 40 73 failed

From: John Center
Subject: Re: [libtool 2.2.6] testsuite: 33 40 73 failed
Date: Wed, 03 Dec 2008 15:29:37 -0500
User-agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv: Gecko/20080421 Lightning/0.9pre Thunderbird/ Mnenhy/

Hi Ralf,

Thanks for getting back to me. I got pulled into another project & had to set this aside until now. I'm going through the cflags now. I'm trying to get a consistent set of options set for the UltraT1/T2 architecture for the various apps we use. I thought since I wasn't using Fortran I didn't need to bother with the settings, but I've found some other apps I'm compiling checking on them, also. I'll add the Fortran flags just to lower the noise level.

Thanks, again.


Ralf Wildenhues wrote:
Hello John, and apologies for the long delay.

* John Center wrote on Wed, Oct 08, 2008 at 02:23:46PM CEST:
Here it is.
[ the testsuite.log file ]

There are essentially three issues.  Quoting selectively, but a bit

## ------------------------- ##
## libtool 2.2.6 test suite. ##
## ------------------------- ##

testsuite: command line was:
  $ /opt/ws/dists/libtool-2.2.6/tests/testsuite MAKE=gmake CC=cc CFLAGS=-g -xO3 
-mt -m64 -xmemalign=8s -xarch=sparcfmaf -xchip=ultraT1 
-xcache=8/16/4:3072/64/12 -xcode=pic32 -xpagesize=4m -fma=fused -xbuiltin 
-xlibmil -xlibmopt -xlic_lib=sunperf CPP=cc -E CPPFLAGS=-I/opt/local/include 
-I/opt/local/include -I/usr/sfw/include LD=/usr/ccs/bin/ld -64 
LDFLAGS=-L/opt/local/lib -R/opt/local/lib -L/usr/sfw/lib -R/usr/sfw/lib 
LIBS=-lumem LN_S=ln -s NM=/usr/ccs/bin/nm -p RANLIB=ranlib STRIP=strip OBJEXT=o 
EXEEXT= SHELL=/bin/bash CONFIG_SHELL=/bin/bash CXX=CC CXXFLAGS=-g -xO3 -mt -m64 
-xmemalign=8s -xarch=sparcfmaf -xchip=ultraT1 -xcache=8/16/4:3072/64/12 
-xcode=pic32 -xpagesize=4m -fma=fused -xbuiltin -xlibmil -xlibmopt 
-xlic_lib=sunperf CXXCPP=CC -E F77=f77 FFLAGS=-g FC=f95 FCFLAGS=-g GCJ= 
GCJFLAGS=-g -O2 _lt_pkgdatadir=/opt/ws/dists/libtool-2.2.6 
uname -m = sun4v
uname -r = 5.10
uname -s = SunOS
uname -v = Generic_127127-11

/usr/bin/uname -p = sparc
/bin/uname -X     = System = SunOS

  33: indirect_deps.at:25 indirect convenience
  40: old-m4-iface.at:40 AM_PROG_LIBTOOL
      libtoolize autoconf
  73: cmdline_wrap.at:28 Run tests with low max_cmd_len

#                             -*- compilation -*-
33. indirect_deps.at:25: testing ...
libtool: compile:  cc -I/opt/local/include -I/opt/local/include 
-I/usr/sfw/include -g -xO3 -mt -m64 -xmemalign=8s -xarch=sparcfmaf 
-xchip=ultraT1 -xcache=8/16/4:3072/64/12 -xcode=pic32 -xpagesize=4m -fma=fused 
-xbuiltin -xlibmil -xlibmopt -xlic_lib=sunperf -c a.c  -KPIC -DPIC -o .libs/a.o
libtool: link: cc -g -xO3 -mt -m64 -xmemalign=8s -xarch=sparcfmaf 
-xchip=ultraT1 -xcache=8/16/4:3072/64/12 -xcode=pic32 -xpagesize=4m -fma=fused 
-xbuiltin -xlibmil -xlibmopt -xlic_lib=sunperf -o .libs/m1 m.o  
-L/opt/local/lib -L/usr/sfw/lib ./.libs/libd.so 
/opt/ws/dists/libtool-2.2.6/tests/testsuite.dir/33/.libs/liba.so -lm -mt 
-R/nowhere -R/opt/local/lib -R/usr/sfw/lib
./indirect_deps.at:62: $LIBTOOL --mode=link --tag=CC $CC $CFLAGS $LDFLAGS $st 
-o m2 m.$OBJEXT libconv.la
libtool: link: cc -g -xO3 -mt -m64 -xmemalign=8s -xarch=sparcfmaf 
-xchip=ultraT1 -xcache=8/16/4:3072/64/12 -xcode=pic32 -xpagesize=4m -fma=fused 
-xbuiltin -xlibmil -xlibmopt -xlic_lib=sunperf -o .libs/m2 m.o  
-L/opt/local/lib -L/usr/sfw/lib ./.libs/libconv.a 
/opt/ws/dists/libtool-2.2.6/tests/testsuite.dir/33/.libs/liba.so -lm -mt 
-R/nowhere -R/opt/local/lib -R/usr/sfw/lib
./indirect_deps.at:64: ./m1; lt_status=$?; if test $lt_status -eq 0; then :;
         elif test "X$host" != "X$build" && \
              { test -x "./m1" || test -x "./m1"$EXEEXT; }
         then (exit 77); else (exit $lt_status); fi
Not enabling shell tracing (command contains an embedded newline)
ld.so.1: m1: fatal: 
/opt/ws/dists/libtool-2.2.6/tests/testsuite.dir/33/.libs/libb.so.0: hardware 
capability unsupported: 0x20  [ VIS ]
/opt/ws/dists/libtool-2.2.6/tests/testsuite.dir/at-test-source: line 53: 21360 
Killed                  ./m1
./indirect_deps.at:64: exit code was 137, expected 0
33. indirect_deps.at:25: 33. indirect convenience (indirect_deps.at:25): FAILED 

This test failure must have something to do with the bunch of CFLAGS you
have supplied.  I cannot tell which, as I have no idea what "hardware
capability VIS" should be.  I have tried to reproduce it on a Solaris 10
system with the same flags, but with this system, the test succeeds.

40. old-m4-iface.at:40: testing ...
./old-m4-iface.at:85: $AUTOCONF --force
/opt/local/bin/autoconf: /usr/local/bin/autom4te: not found
./old-m4-iface.at:85: exit code was 1, expected 0
40. old-m4-iface.at:40: 40. AM_PROG_LIBTOOL (old-m4-iface.at:40): FAILED 

Hmm.  Looks like an installation problem of Autoconf on your side.

73. cmdline_wrap.at:28: testing ...
./cmdline_wrap.at:43: $CONFIG_SHELL $abs_srcdir/testsuite -k libtool 
ERROR: 29 tests were run,
6 failed (3 expected failures).
 21: F77 convenience archives                        FAILED (convenience.at:153)
 22: FC convenience archives                         FAILED (convenience.at:213)
 33: indirect convenience                            FAILED 

The Fortran issues are new in this sub-test, the indirect convenience is
the same as above.  Let's look at the Fortran one:

21. convenience.at:109: testing ...
libtool: compile:  f77 -g -c a3.f -o a3.o >/dev/null 2>&1
libtool: link: ar cru .libs/liba3.a .libs/a3.o
libtool: link: ranlib .libs/liba3.a
libtool: link: ( cd ".libs" && rm -f "liba3.la" && ln -s "../liba3.la" 
"liba3.la" )
/convenience.at:151: $LIBTOOL --tag=F77 --mode=link $F77 $FFLAGS $LDFLAGS -o 
liba12.la liba1.la liba2.la -rpath /notexist
libtool: link: f77 -G -h liba12.so.0 -o .libs/liba12.so.0.0.0  -z allextract 
./.libs/liba1.a ./.libs/liba2.a -z defaultextract  -R/opt/local/lib 
-R/usr/sfw/lib -L/opt/local/lib -L/usr/sfw/lib
NOTICE: Invoking /opt/ws/tools/SUNWspro/bin/f90 -f77 -ftrap=%none -G -h 
liba12.so.0 -o .libs/liba12.so.0.0.0 -z allextract ./.libs/liba1.a 
./.libs/liba2.a -z defaultextract -R/opt/local/lib -R/usr/sfw/lib 
-L/opt/local/lib -L/usr/sfw/lib
libtool: link: (cd ".libs" && rm -f "liba12.so.0" && ln -s "liba12.so.0.0.0" 
libtool: link: ( cd ".libs" && rm -f "liba12.la" && ln -s "../liba12.la" 
"liba12.la" )
/convenience.at:153: $LIBTOOL --tag=F77 --mode=link $F77 $FFLAGS $LDFLAGS -o 
liba123.la a3.lo liba1.la liba2.la -rpath /notexist
ld: fatal: file .libs/a3.o: wrong ELF class: ELFCLASS32
ld: fatal: File processing errors. No output written to .libs/liba123.la-1.o
libtool: link: /usr/ccs/bin/ld -64 -r -o .libs/liba123.la-1.o .libs/a3.o
/convenience.at:153: exit code was 1, expected 0
21. convenience.at:109: 21. F77 convenience archives (convenience.at:109): 
FAILED (convenience.at:153)

I can reproduce this failure.  It is due to the fact that you pass flags
for C and C++ compilers to use 64bit binaries, but not for Fortran 77
and Fortran.  Adding -m64 for FFLAGS and FCFLAGS at configure time
removes these failures.  The "low max_cmd_len" test will still fail on
your system because it reruns the indirect_deps test discussed above.


John Center
Villanova University

reply via email to

[Prev in Thread] Current Thread [Next in Thread]