[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Recurring calls eat up memory

From: Ralf Wildenhues
Subject: Re: Recurring calls eat up memory
Date: Sun, 21 Dec 2008 21:42:29 +0100
User-agent: Mutt/1.5.18 (2008-05-17)

Hello Andres,

thanks for the report.

* Andres Chavarria wrote on Sun, Dec 21, 2008 at 04:28:09PM CET:
> I installed yesterday OpenSuSE 11.1 and tried to use KDevelop (3.5.3
> openSuSE) to create and compile a simple project. When KDevelop calls
> libtool to link the program, the computer begins to slow down due to
> massive memory consumption until it does not react anymore.


> I tracked down the problem to the script "libtool" found in the
> projects "debug" or "optimized" directories, which I guess is produced
> by libtool. It seems that the script calls itself recurringly and
> produces more and more processes.

Weird.  This is the first time we hear about this.

> There seems to be a problem with case sensitivity in the script with
> the "echo" program definition. Changing the script solved the problem:
> instead of defining the "echo" as follows:
> # An echo program that protects backslashes.
> ECHO="printf %s\\n"
> I used:
> # An echo program that protects backslashes.
> echo="printf %s\\n"

That's pretty weird.  Libtool 2.2.x should not use $echo anywhere.
Can you post the output of
  ./libtool --config
  grep '\$echo' ./libtool

for the two libtool scripts that you found?


reply via email to

[Prev in Thread] Current Thread [Next in Thread]