[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[PATCH] libtool ignores unresolved symbols despite -no-undefined flag

From: Torsten Landschoff
Subject: [PATCH] libtool ignores unresolved symbols despite -no-undefined flag
Date: Sun, 15 Nov 2009 04:16:34 +0100
User-agent: Mutt/1.5.20 (2009-06-14)

Dear libtool maintainer(s),

While working on an internal project, I ran into the problem that I was
building a shared object that was missing external dependencies. I noticed
the problem only after the build result was installed and loaded (it is
a plugin), which failed because of the unresolved symbols.

Reading the libtool manual, I found the -no-undefined flag which looked
like it would do the trick for me. Unfortunately, it has no effect on my
Debian GNU/Linux system. Lately, I ran into a similar problem with my Debian
package of the FOX widget toolkit.

I think, GNU libtool should indead report an error if building with
-no-undefined even on systems where undefined symbols are allowed. That
way, one will notice during development that a feature is used that
may not be available on the target system.

Scratching my small itch, I did my best to create a unit test for this
issue and to fix the implementation. The patches are attached and can
be pulled from my git repo at

git://landschoff.net/git/libtool.git (branch fix-no-undefined)

as well.

I would be glad if this small contribution would find its way into the
official libtool.

Greetings, Torsten

Attachment: 0001-Add-a-test-case-Undefined-symbols-are-an-error-with-.patch
Description: Text Data

Attachment: 0002-Take-the-no-undefined-flag-into-account-on-Linux-GCC.patch
Description: Text Data

Attachment: 0003-Check-that-no-undefined-notices-undefined-symbols-fo.patch
Description: Text Data

Attachment: 0004-Pay-attention-to-no-undefined-for-g-gnu-ld-as-well.patch
Description: Text Data

Attachment: 0005-Move-no-undefined-tests-out-of-Darwin-group.patch
Description: Text Data

reply via email to

[Prev in Thread] Current Thread [Next in Thread]