bug-libtool
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#12304: libtool parse of nagfor -Wl,-Wl,, gives incorrect result


From: Thomas Jahns
Subject: bug#12304: libtool parse of nagfor -Wl,-Wl,, gives incorrect result
Date: Thu, 30 Aug 2012 12:32:09 +0200
User-agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.1.16) Gecko/20120724 Iceowl/1.0b1 Icedove/3.0.11

Hello,

On 08/29/2012 01:56 PM, Thomas Jahns wrote:
> I'm not sure of the best way to address this unfortunate coincidence of 
> compiler
> and libtool flags. My, perhaps naïve, idea would be to test whether an 
> argument
> starting with -Wl, also matches $wl and, in case $wl does not equal "-Wl," 
> pass
> the flag argument on to the linker unaltered.

I've now prepared a patch vs. the repository state that seems to work for me[1].

Regards, Thomas

[1] Tested with
- gfortran/gcc on Debian GNU/Linux 6.0.5 i386/x86_64
- nagfor/gcc on Debian GNU/Linux 6.0.5 i386/x86_64
- ifort/icc on Debian GNU/Linux 6.0.5 i386/x86_64
- xlf/xlc on AIX 6.1 Power6

P.S.: I'll try CentOS 5.6 Linux x86_64 with ifort/icc and nagfor/gcc and
gfortran/gcc next but can't say when I'll get around to that because I'll need
to fix an unrelated bug with mpxlf on AIX first.
-- 
Thomas Jahns
DKRZ GmbH, Department: Application software

Deutsches Klimarechenzentrum
Bundesstra├če 45a
D-20146 Hamburg

Phone: +49-40-460094-151
Fax: +49-40-460094-270
Email: Thomas Jahns <address@hidden>

Attachment: 0001-Fix-handling-of-Wl-Wl-argument-prefix-of-NAG-fortran.patch
Description: Text Data

Attachment: smime.p7s
Description: S/MIME Cryptographic Signature


reply via email to

[Prev in Thread] Current Thread [Next in Thread]