bug-libtool
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug#18099: AIX TLS symbols do not make it into dynamic libraries


From: Thomas Jahns
Subject: bug#18099: AIX TLS symbols do not make it into dynamic libraries
Date: Thu, 24 Jul 2014 16:40:50 +0200
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:24.0) Gecko/20100101 Icedove/24.6.0

Hello,

we encountered some problems when building an OpenMP application/library package
because of a missing symbol on AIX 6.1 TL8 running on an IBM Power6 system.

We traced the problem down to an omission in libtool: since the matching string
for AIX

  symcode='[[BCDT]]'

does not include global TLS symbols (letter L of AIX nm) we faced a problem with
a symbol compiled into an object and visible in the static version of the
library being invisible in the shared library object.

In short: could someone add L to above symcode assignment (line 3748 in
build-aux/ltmain.in)?

Also when reading the AIX nm manual page[1] I see that letter A for global
absolute symbols is equally unrecognized. So it might make sense to add that as
well but have no test case for that.

Regards, Thomas

[1] Can be searched on the Internat as AIX "Commands Reference, Volume 4: n
through r", I found it at

<http://www-01.ibm.com/support/knowledgecenter/api/content/ssw_aix_71/com.ibm.aix.cmds4/aixcmds4_pdf.pdf>
page 216
-- 
Thomas Jahns
DKRZ GmbH, Department: Application software

Deutsches Klimarechenzentrum
Bundesstra├če 45a
D-20146 Hamburg

Phone: +49-40-460094-151
Fax: +49-40-460094-270
Email: Thomas Jahns <address@hidden>

Attachment: smime.p7s
Description: S/MIME Cryptographic Signature


reply via email to

[Prev in Thread] Current Thread [Next in Thread]