[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: build fail in 2.1.0 CVS

From: Graham Percival
Subject: Re: build fail in 2.1.0 CVS
Date: Fri, 21 Nov 2003 20:43:19 -0800

On Mon, 17 Nov 2003 09:52:38 +0100
Jan Nieuwenhuizen <address@hidden> wrote:
> Graham Percival <address@hidden> writes:
> > Here's the output.  Does anybody know what LilyPond is trying to do
> > after it reads the files from Documentation/user, input/regression,
> > and input/test ?
> Why do you think it is lilypond?  You'll have to find the command that
> fails:

I'm not convinced the root of the problem was LilyPond, but something
changed between 2.0.1 and 2.1.0 -- I can build 2.0.1 without this
problem.  So either there's a bug in LilyPond that was introduced
between those two releases, or LilyPond is discovering a bug in
something else.  It looks like LilyPond's discovered a bug in gs.

> > Reading `/home/gperciva/dev/lilypond/mf/out/parmesan16list.ly'
> > Invoking `gs -sDEVICE=bbox -q -dNOPAUSE lily-1292174260.eps -c quit
> > 2>lily-1292174260.eps.bbox'Error: /rangecheck in --setdash-- Operand
> > stack:
> Have you tried:
>     gs -sDEVICE=bbox -q -dNOPAUSE lily-1292174260.eps -c quit 2> bbox
> The -1292174260 part of the eps file is the hash of its contents, and
> my build generates that file too, so the file is ok.

That command produces the same error message.  Debian's bug tracking
system appears to be down right now (they're probably searching for clues
from that crack), but I'll file a report about gs when it's up again.

- Graham

reply via email to

[Prev in Thread] Current Thread [Next in Thread]