[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Segmentation fault on 2.5.13/FC3 + guile-config/libguile?

From: Marcus Macauley
Subject: Segmentation fault on 2.5.13/FC3 + guile-config/libguile?
Date: Tue, 1 Mar 2005 23:08:45 +0000
User-agent: Mutt/1.5.6i


I just did a fresh install of Fedora Core 3 (i386) on my Athlon 64. Then I 
downloaded and installed 
followed by 
http://lilypond.org/download/fonts/ec-fonts-mftraced-1.0.9-1.noarch.rpm and the 
latest Lilypond package, 2.5.13, for FC3: 

I logged out and back in, as instructed, and now when I try to run lilypond on 
a file, it displays the following terse error message and quits:

GNU LilyPond 2.5.13
Segmentation fault

I can do lilypond --help or lilypond --version alright, but anything else, even 
just lilypond, results in the error above.

Any ideas?

Also, I just removed the RPM by rpm -e lilypond, and now I'm trying to build it 
from source (still 2.5.13). However, I'm confused about the GUILE requirement. 
The INSTALL file 
lists, among the compilation requirements:

GUILE  (version 1.6.5 or newer). If you are installing a binary packages, you 
may need to install guile-devel or guile-dev or libguile-dev too.

I followed the link to the GUILE website, downloaded the latest version 
(http://ftp.gnu.org/pub/gnu/guile/guile-1.6.7.tar.gz), and installed it 
according to the instructions with ./configure and make. However, when running 
./configure on Lilypond, it still complains about guile-config and libguile:

ERROR: Please install required programs:  echo no guile-config >= 1.6.5 
(installed: ) libguile (libguile-dev, guile-devel or guile-dev package). 
mftrace fontforge

Where do I get guile-config and libguile? I don't see them mentioned on the 
GUILE website, and if they need to be gotten from somewhere else, I would have 
expected to find a link in the lilypond INSTALL.html file.

Thanks in advance for any help/advice,
Marcus Macauley

reply via email to

[Prev in Thread] Current Thread [Next in Thread]