[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: MacOS build failure

From: Graham Percival
Subject: Re: MacOS build failure
Date: Mon, 28 Mar 2005 13:28:58 -0800

On 27-Mar-05, at 3:50 PM, Han-Wen Nienhuys wrote:
trying to build 2.5.16 on MacOS X 10.3, the link fails with

I'm sure that you've done something like this already, but just in case
it helps, here's my current setup for compiling lilypond.  It worked
for 2.5.15; I can't remember if I've tested it on 2.5.16.

cd ~/usr/src
# stuff from lilypond-unstable.info

export PKG_CONFIG_PATH=/sw/lib/pango-ft219/lib/pkgconfig:/sw/lib/fontconfig2/ lib/pkgconfig:/sw/lib/freetype2
export PYTHON=/sw/bin/python2.3 GUILE=/sw/bin/guile-1.6 GUILE_CONFIG=guile-1.6-config
# kpathsea setup
export LDFLAGS="-L/sw/lib/ -L/sw/lib/pango-ft219/lib"
export CPPFLAGS="-I/sw/include/ -no-cpp-precomp"

cd lilypond
patch -p1 < ../lilypond-devel.patch
#patch -p1 < ../bak-unstable.patch
PREFIX=/sw ./lexer-gcc-3.1.sh
nice ./autogen.sh --prefix $HOME/usr/pkg/lilypond --disable-optimising

Then I do the standard make; make install. make web doesn't work, though. I've got an "unfink.sh" which removes fink's lilypond-devel.patch ; I run that
before doing a cvs ci.

- Graham

reply via email to

[Prev in Thread] Current Thread [Next in Thread]