[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: difficulties with installing

From: Timothy Heath
Subject: Re: difficulties with installing
Date: Tue, 27 Sep 2005 07:18:29 -0500
User-agent: KMail/1.4.3

Jobst, Mats,

I wrote earlier to the list regarding my own difficulty installing a Lilypond 
autopackage to a SuSE 9.0 system.  I had received the same message as Jobst 
did when I tried to install the lilypond autopackage.  One person did kindly 
respond to me privately, but his experience was with compiling and installing 
Lilypond from source to a SuSE system.

Eventually, I found that you need an RPM package called Python21 installed on 
your SuSE system to get beyond this error.  According to the description 
given in YAST, the standard Python interpretor is a later version that has 
some bugs, and some programs specifically require Python version 2.1.  I 
guess lilypond must be among these.

Unfortunately, Jobst, installing python21 will still not get you to having 
lilypond on your SuSE 9.1 system.  After installing python21, my attempt to 
install the lilypond autopackage produced a message that said "Ghostscript 
not found".  This message is surprising (and misleading), as the lilypond 
autopackage does itself contain the ghostscript 8.15 autopackage.  I 
extracted the lilypond autopackage and attempted to install directly the 
ghostscript package.  That attempt gave the message "libpng not found."  
Ghostscript 8.15 requires a later version of libpng than is present in 
distros with ghostscript 7.  Therefore, although the autopackage provides 
ghostscript 8.15, it does not provide the libpng version needed for 
ghostscript's installation.  Libpng in turn has requirements, but I have not 
pursued whether these are sufficiently up to date on a SuSE system.

There are, I believe, three solutions to Jobst's problem.  Jobst, I wrote to 
you privately with two of these suggestions, but I don't know if you got 

Solution 1:  Upgrade to SuSE 9.3.  This version of SuSE has ghostscript 8.15, 
and therefore (I think!)  the lilypond autopackage should install without 
incident, as long as you install python21.  I am going to try this myself and 
will report the result to this list.

Soluiton 2:  Upgrade Ghostscript to version 8.15 in your SuSE 9.1 distro.  
This approach will be harder to do, and may involve compiling ghostscript and 
all dependencies from source.  If anyone can give guidelines on how to do 
this it would be very helpful.

Solution 3:  Is there any chance that the lilypond team might add all the 
ghostscript requirements to the autopackage?

Tim Heath

>From the error message it seems that the simple solution is
>to install python. I don't know any details about SuSE, but
>I'm sure that you can find one or more packages called python*.

>It seems that your email took some time to reach the list,
>since emails from people not subscribed to the list are
>first checked manually by one of the list moderators, otherwise
>the policy is to always reply both to the list and the the
>sender directly.

>   /Mats

>>Jobst Harders wrote: 

>>I would like to install lilypond on my system, using SuSE 9.1.

>>I tried downloading the .package pack, but get the error message that python 
>>language runtime is not available. Is it impossible to install a ".package" 
>>program under SuSE (as i heard someone saying)?
>>What other possibilities are there to get Lilypond working on my computer?

>>Sorry, i am new to the list; maybe someone could let me know if I first have 
>>to become a registered member to get the answers or what else is to do.
>>Thanks in advance!

>>Kind regards,
>>Jobst Harders, Utrecht

Timothy D. Heath
Associate Professor of Pharmaceutics
School of Pharmacy
777 Highland Avenue
Madison, WI 53705 2222
Tel: 608 263 3986
FAX: 608 262 5345

reply via email to

[Prev in Thread] Current Thread [Next in Thread]