[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] - autopackage fails, debuild fails

From: Gilles
Subject: - autopackage fails, debuild fails
Date: Thu, 6 Oct 2005 19:30:28 +0200
User-agent: Mutt/1.5.11


This is a copy of a previous message to the "user" ML, to which
I didn't receive any answer (because it was posted to the wrong

Best regards,
--- Begin Message --- Subject: - autopackage fails, debuild fails Date: Wed, 5 Oct 2005 01:45:15 +0200 User-agent: Mutt/1.5.11

I tried to install the latest stable.  Again, like a few months
ago, I couldn't get very far with "autopackage".  It fails with
the following error:

$ sh lilypond-
/usr/libexec/autopackage/autosu-gtk: error while loading shared libraries: 
libgtk-x11-2.0.so.0: cannot open shared object file: No such file or directory

But the file is there:

$ ls -l /usr/lib/libgtk-x11-2.0.so.0
lrwxrwxrwx  1 root root 26 Sep 27 01:33 /usr/lib/libgtk-x11-2.0.so.0 -> 
$ ls -l /usr/lib/libgtk-x11-2.0.so.0.600.10
-rw-r--r--  1 root root 3233696 Sep  2 02:39 /usr/lib/libgtk-x11-2.0.so.0.600.10

I'd prefer installing through the Debian management system, but no new
version is provided on the web site :-(

Hence I tried to create the deb package following the instructions
provided in http://lilypond.org/web/devel/packaging

But it also failed:

programming error: setting to zero
continuing, cross fingers
Converting to PNG...Error: /rangecheck in --glyphshow--
Operand stack:

Execution stack:
   %interp_exit   .runexec2   --nostringval--   --nostringval--   
--nostringval--   2   %stopped_push   --nostringval--   --nostringval--   
--nostringval--   false   1   %stopped_push   1   3   %oparray_pop   1   3   
%oparray_pop   --nostringval--   1   3   %oparray_pop   1   3   %oparray_pop   
.runexec2   --nostringval--   --nostringval--   --nostringval--   2   
%stopped_push   --nostringval--   --nostringval--   --nostringval--   
--nostringval--   --nostringval--
Dictionary stack:
   --dict:1122/1686(ro)(G)--   --dict:0/20(G)--   --dict:122/200(L)--
Current allocation mode is local
Last OS error: 2
Current file position is 160679
GPL Ghostscript 8.15: Unrecoverable error, exit code 1
GS exited with status: 256lilypond-book.py: warning: `lilypond' failed (status 
1) (ignored)

lilypond-book.py: error: Process 
--backend=eps --formats=ps,png --header=texidoc -I ./input/test 
-dinternal-type-checking -danti-alias-factor=2  -I 
/home/eran/tmp/music/lilypond/build/lilypond-2.6.3/Documentation/user  -I 
/home/eran/tmp/music/lilypond/build/lilypond-2.6.3/Documentation/user  -I 
-I /home/eran/tmp/music/lilypond/build/lilypond-2.6.3/input  -I 
/home/eran/tmp/music/lilypond/build/lilypond-2.6.3/input/regression  -I 
/home/eran/tmp/music/lilypond/build/lilypond-2.6.3/input/test  -I 
/home/eran/tmp/music/lilypond/build/lilypond-2.6.3/input/tutorial  -I 
/home/eran/tmp/music/lilypond/build/lilypond-2.6.3/mf/out  -I 
/home/eran/tmp/music/lilypond/build/lilypond-2.6.3/mf/out snippet-map.ly 
lily-3705696861225032097 lily-7907740514497884012 lily-4814538859644880155 
lily-7067873181222770626 lily-2768510490762665945 lily-1908769927333312427 
lily-2767080990388832677 lily-8667684011072532527 lily-1976875858654905403 
lily-1701737285256890539 lily-3916362202340365756 lily-4488696071821053747 
lily-2289784821850203558 lily-8057330632707758553 lily-5168569587237257497 
lily-1080231535713411076 lily-8994431641596651646 lily-690447926148161617 
lily-6681840175093875524 lily-501219599963062705 exited unsuccessfully.
Removing `introduction.texi'
Removing `lilypond.texi'
Traceback (most recent call last):
  File "../../scripts/lilypond-book.py", line 1616, in ?
    main ()
  File "../../scripts/lilypond-book.py", line 1599, in main
    ly.exit (1)
 line 139, in exit
    raise _ ('Exiting (%d)...') % i
Exiting (1)...
make[4]: *** [out-www/lilypond.texi] Error 1
make[4]: Leaving directory 
make[3]: *** [WWW] Error 2
make[3]: Leaving directory 
make[2]: *** [WWW] Error 2
make[2]: Leaving directory `/home/eran/tmp/music/lilypond/build/lilypond-2.6.3'
make[1]: *** [web] Error 2
make[1]: Leaving directory `/home/eran/tmp/music/lilypond/build/lilypond-2.6.3'
make: *** [build-doc-stamp] Error 2
debuild: fatal error at line 765:
dpkg-buildpackage failed!

It seems that the documentation is causing the problem...

Does someone still maintain the debian packages?
I would be willing to help if necessary (although currently,
I know very little about deb packaging).

Thanks and best regards,

--- End Message ---

reply via email to

[Prev in Thread] Current Thread [Next in Thread]