[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: - autopackage fails, debuild fails

From: Jan Nieuwenhuizen
Subject: Re: - autopackage fails, debuild fails
Date: Thu, 06 Oct 2005 23:48:42 +0200
User-agent: Gnus/5.1003 (Gnus v5.10.3) Emacs/21.3.50 (gnu/linux)

Gilles writes:

> This is a copy of a previous message to the "user" ML, to which
> I didn't receive any answer (because it was posted to the wrong
> ML?).

Yes, this

> $ sh lilypond-
> /usr/libexec/autopackage/autosu-gtk: error while loading shared libraries: 
> libgtk-x11-2.0.so.0: cannot open shared object file: No such file or directory

looks like an autopackage error.  It seems you have autopackage
installed on your system, can you try what happens if you remove
autopackage?  The lilypond install command should still work,
it has autopackage on board.

> I'd prefer installing through the Debian management system, but no new
> version is provided on the web site :-(

Yes, that's very sad.  LilyPond's dependencies in Debian have been
stalled for quite some time.

> Hence I tried to create the deb package following the instructions
> provided in http://lilypond.org/web/devel/packaging

> Execution stack:
>    %interp_exit   .runexec2   --nostringval--   --nostringval--   
> --nostringval--   2   %stopped_push   --nostringval--   --nostringval--   
> --nostringval--   false   1   %stopped_push   1   3   %oparray_pop   1   3   
> %oparray_pop   --nostringval--   1   3   %oparray_pop   1   3   %oparray_pop  
>  .runexec2   --nostringval--   --nostringval--   --nostringval--   2   
> %stopped_push   --nostringval--   --nostringval--   --nostringval--   
> --nostringval--   --nostringval--
> Dictionary stack:
>    --dict:1122/1686(ro)(G)--   --dict:0/20(G)--   --dict:122/200(L)--
> Current allocation mode is local
> Last OS error: 2
> Current file position is 160679
> GPL Ghostscript 8.15: Unrecoverable error, exit code 1

Hmm, that should have worked, but I'm using gs-afpl 8.50.  Any success
stories of compiling lilypond-2.6.3 with gs-8.15?

> It seems that the documentation is causing the problem...


> Does someone still maintain the debian packages?

Only for the regular Debian releases, but Debian is still at 2.4, as
2.6 does not yet build because of missing dependencies.

> I would be willing to help if necessary (although currently,
> I know very little about deb packaging).


Jan Nieuwenhuizen <address@hidden> | GNU LilyPond - The music typesetter
http://www.xs4all.nl/~jantien       | http://www.lilypond.org

reply via email to

[Prev in Thread] Current Thread [Next in Thread]