[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Possible bug - program acts strange if .ly file has special characte

From: Graham Percival
Subject: Re: Possible bug - program acts strange if .ly file has special characters
Date: Sun, 08 Apr 2007 20:36:27 -0700
User-agent: Thunderbird (Macintosh/20070221)

Han-Wen, do we officially support such filenames?

I created a file called

when I tried to compile it on the command-line, I typed in "f<TAB>" and OSX produced
lilypond foa\314\200o.ly

which ended up with:
Preprocessing graphical objects...
Layout output to `foào.ps'...
Converting to `foào.pdf'...
`gs -q -dSAFER -dDEVICEWIDTHPOINTS=595.28 -dDEVICEHEIGHTPOINTS=841.89 -dCompatibilityLevel=1.4 -dNOPAUSE -dBATCH -r1200 -sDEVICE=pdfwrite -sOutputFile="foa?\x80o.pdf" -c .setpdfwrite -f "foa?\x80o.ps"' failed (256) programming error: Parsed object should be dead: static scm_unused_struct* Prob::mark_smob(scm_unused_struct*)
continuing, cross fingers
... (similar errors)

While I was playing around with different ways to call the file, I came across this:
lilypond fo\303\240o.ly

which worked just fine.

It looks like OSX's handling of utf8 filenames is a complete mess, but I don't have any experience with non-ascii text so maybe there's an easy fix. Should I add this to the tracker?

- Graham

Griff Miller wrote:
MacOS X on Intel
Lilypond Version 2.11.21-1 (Build from Sat Mar 24 16:13:25)

If my input file is named "La oración del torero.ly" then Lilypond churns
forever when I do Compile->Typeset file .  If I rename it "La oracion del
torero.ly" it works fine.

bug-lilypond mailing list

reply via email to

[Prev in Thread] Current Thread [Next in Thread]