[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

installing lilypond

From: Graham Norton
Subject: installing lilypond
Date: Wed, 15 Jul 2009 11:40:40 +0000 (UTC)
User-agent: Loom/3.14 (http://gmane.org/)

Hello. I tried installing lilypond tonight on my iMac, OS v. 10.5.7. I am an
experienced TexShop user.

I created the lilypond.engine file for bash in TeXShop (you should say this text
file needs a .engine extension) and moved it into the TeXShop engine directory.
Then I did chmod +x on the file from terminal.

A window saying successful installation (which included a scale program) came
onto my desktop.

It said I should copy this window and compile it. I was unable to copy it (by
selecting it and pressing apple key c, which beeped) and so could not compile 

Anyway, I went into TexShop and typed in the \header{ } etc. (with a few 
initial comments) and changed the file extension to .ly but it failed to compile
in lilypond (from the typesetting button) and so there is no pdf file.

Should I have surrounded it with latex commands (\documentclass etc.)??

Here is the file (which I called scale.ly) that I tried to compile:

Welcome to Lilypond
title="A scale in Lilypond"}
\relative{c d e f g h a b c}
\version "2.12.2"

Why won't this compile and produce pdf output? As far as I can tell, I followed
the instructions exactly....

Thanks for your help.

Graham Norton

reply via email to

[Prev in Thread] Current Thread [Next in Thread]