[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Rename \unHideNotes to \unhideNotes

From: Mark Polesky
Subject: Re: Rename \unHideNotes to \unhideNotes
Date: Sat, 25 Jul 2009 09:34:09 -0700 (PDT)

Dénes Harmath wrote:
> Mark Polesky wrote:
> > This suggests that the command is derived from "hideNotes":
> > "un" + "hideNotes" = "unHideNotes"
> That logic isn't applied in the case of \set and \unset. That's
> why I am (and maybe also others are) always confused.

Oh, I hadn't thought of that.

> Sorry for nitpicking about syntax issues, but a consistent
> convention is easier to remember.

Absolutely no need to apologize for nitpicking about syntax
issues, especially to me! (: I'm a stickler for consistency (among
other things).

But as you know, syntax changes are not made lightly. If enough
developers agree that a change is preferable, then perhaps it will
be made.

\unset -> \unSet
\unHideNotes -> \unhideNotes

If I had to pick one, I'd pick the second one, since it means less
capitals (less holding down the <SHIFT> key). But I'm by no means
in charge of these sorts of things.

Anyone else care to comment?

- Mark

reply via email to

[Prev in Thread] Current Thread [Next in Thread]