[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Rename \unHideNotes to \unhideNotes

From: lilypondtool
Subject: Re: Rename \unHideNotes to \unhideNotes
Date: Sun, 26 Jul 2009 14:56:54 +0200
User-agent: Internet Messaging Program (IMP) H3 (4.0.4)

The general rule in the CamelCaseWorld is to change the case on word boundaries.
In this sense I also think that unhideNotes should be unhideNotes.
Also for a user syntactic keywords and variables are indistinguishable.
(And not just for users, as if I remember well \override is a music function in markup mode and a keyword in note mode)


Quoting Nicolas Sceaux <address@hidden>:

Le 25 juil. 09 à 11:39, Dénes Harmath a écrit :

On 2009.07.23., at 21:58, Mark Polesky wrote:
This suggests that the command is derived from "hideNotes":
"un" + "hideNotes" = "unHideNotes"

That logic isn't applied in the case of \set and \unset. That's why I am (and
maybe also others are) always confused.

But then \set and \unset are so-called keywords, like eg. \lyricsto,
etc, and these are not capitalized, whereas \hideNotes and
\unHideNotes are
variables (where capitilization applies).  So this is consistent.

bug-lilypond mailing list

reply via email to

[Prev in Thread] Current Thread [Next in Thread]