[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Bug: wrong notehead

From: Garrett McGilvray
Subject: Re: Bug: wrong notehead
Date: Sun, 20 Oct 2013 21:42:27 -0500

I stumbled on some further information about this \aikenHeads bug. I earlier 
said that 2.17.28 seems to fix it. I have since discovered that oddly the 
half-note is fixed but the problem is traded for the whole note. Here is an 
improved snippet:

\relative c' {
c2 d e f c1 d

%{ explanation:
In 2.16.2 the second half note is solid when it should be hollow
In 2.17.28 the second whole note is solid when it should be hollow

Again, Mac OS 10.8.5

On Oct 11, 2013, at 9:23 AM, Garrett McGilvray <address@hidden> wrote:

> I have done a little further testing, and I found that the same bad output 
> occurs on 2.16.2-1 on my Macbook Pro at work. However, I have tested 2.17.28 
> on both machines, and it works correctly on both. I was certain that I had 
> already tried it on 2.17.28 earlier and it didn't work, but maybe I was 
> imagining things. The beta version does work correctly, so it looks like it 
> will be fixed for the next release.
> Additionally, I tested in 2.16.2 on Windows 8.1, and it works fine there. To 
> summarize, of all the combinations I tried, it works correctly everywhere 
> except 2.16.2 on Mac.
> For reference, this was the original example:
>> %The fa half note in aikenHeads renders as a quarter note
>> \version "2.16.2"
>> \relative c' { \aikenHeads c2 d e f } % The d notehead is solid instead of
>> hollow
> On Oct 11, 2013, at 9:02 AM, Graham King <address@hidden> wrote:
>> Confirmed.  Lilypond 2.16.2 on OSX 10.6.8.  Output attached.
>> On Wed, 2013-10-09 at 22:50 +0200, Marek Klein wrote:
>>> I have different result with  GNU/Linux x86: LilyPond 2.16.2-1. Could
>>> someone on Mac OS confirm this behaviour?
>>> Marek
>>> bug squad member
>> <Aikenheads.xcf>

reply via email to

[Prev in Thread] Current Thread [Next in Thread]