[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: readline, .guile and ly/scheme-sandbox.ly

From: David Kastrup
Subject: Re: readline, .guile and ly/scheme-sandbox.ly
Date: Fri, 03 Jan 2014 01:04:15 +0100
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/24.3.50 (gnu/linux)

Luis Mochan <address@hidden> writes:

> I prepared a .guile file in my home directory with the contents
>   (use-modules (ice-9 readline))
>   (activate-readline)
> If I run guile directly, it works and I have readline available. However, if 
> I run 
>   lilypond scheme-sandbox
> I get the message
> GNU LilyPond 2.18.0
> Processing `/home/mochan/lilypond/usr/share/lilypond/current/ly/scheme-
> sandbox.ly'
> Parsing...
> /home/mochan/lilypond/usr/share/lilypond/current/ly/scheme-sandbox.ly:3:2: 
> error: GUILE signaled an error for the expression beginning here
> #
>  (load-user-init)
> readline is not provided in this Guile installation
> and readline is not available.
> If I remove my .guile file lilypond shows no error, but I still have no 
> readline.

You need to install the readline library.  On my system, it is provided
by the guile-1.8-libs package.  Note that more often than not, any GUILE
provided by the system is GUILE 2.0, and its libraries are not useful
for GUILE 1.8 which LilyPond uses.

David Kastrup

reply via email to

[Prev in Thread] Current Thread [Next in Thread]