[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Ghostscript problem in 2.19.18

From: Masamichi HOSODA
Subject: Re: Ghostscript problem in 2.19.18
Date: Wed, 15 Apr 2015 21:42:02 +0900 (JST)

>> How do you install lilypond-2.19.18-1.linux-x86.sh?
> I execute the script as user to install it to ~/lilypond (with the
> wrappers in ~/bin).
> Then (and that's maybe where the problem starts) I move the ~/lilypond
> folder to the location on /shared and create a symlink at ~/lilypond.
> This is what I've always done and what has always worked.

How do you move and create symlink them?
symlink's symlinks are OK?

>> gs requires its resource files (gs_init.ps etc.).
>> It finds them by environment variable GS_LIB or its built in search
>> path.
> echo $GS_LIB doesn't return anything.

GS_LIB is set by lilypond.
And it is unset when lilypond is finished.

> If I run gs --version on the gs file inside the lilypond-2.19.18-1
> installation it returns "9.05"!

Your system's gs is 9.05.
It is not 9.10.

gs executable is just a loader.
It loads and calls libgs.

gs-9.15 executable loads libgs.so.9.
lilypond included libgs.so.9 is symlink to libgs.so.9.15.
Both files in lilypond's libraries directory.

By the default,
lilypond's libraries directory is not in library search path.

Perhaps, your system's libgs.so.9 is symlink to libgs.so.9.05,
and both files are in library search path.
So, lilypond included gs executable loads your system's libgs.
It is 9.05.

On the other hands,
lilypond-2.19.17-1.linux-x86.sh includes gs-8.70.
Its gs executable loads libgs.so.8.
If your system has libgs.so.8 and it is symlink to libgs.so.8.70,
lilypond-2.19.17 works fine.

> I just installed 2.19.18-1 again and left it in its default location
> ~/lilypond.
> Now everything works.
> Can it be that there's some hardcoded path anywhere, so the included
> gs isn't found anymore?
> But if that's the case I think it should be fixed because I should be
> able to move around the actual lilypond installation - and it did work
> up to 2.19.17

If I understand correctly,
~/lilypond/ files don't have hardcoded absolute path.
However, ~/bin/ wrapper script files have absolute path.

~/bin/lilypond wrapper script set LD_LIBRARY_PATH
for changing library search path.

If you move installed ~/lilypond/ files,
I recommend to rewrite ~/bin/lilypond wrapper script.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]