[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Possible bug with new \partial

From: Simon Albrecht
Subject: Re: Possible bug with new \partial
Date: Sun, 16 Aug 2015 22:59:08 +0200
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:31.0) Gecko/20100101 Thunderbird/31.8.0

Am 16.08.2015 um 22:32 schrieb Mats Bengtsson:

On 08/16/2015 10:05 PM, Simon Albrecht wrote:
Hello Mats,

IIUC \partial serves to insert an additional amount of time, however in this example we actually need to skip a beat – thus call \partial with a negative duration, which is impossible :-) So you need to insert \set Timing.measureLength = #(ly:make-moment 3/4) before the second bar in your example. Is this documented differently? Else I wouldn’t consider it a bug, rather an inherent limitation.
Please note that \partial has been changed very recently in the 2.19 versions. The documentation for 2.19.25, http://lilypond.org/doc/v2.19/Documentation/notation/displaying-rhythms#index-_005cpartial-1 says that the duration specifies the remaining length of the current measure, which in my example is zero.
You’re right of course. I should’ve looked there.
Note also that my example works fine if I remove the R2*3 line directly below \time 3/4.
Not quite: no (default) bar line is drawn.
Apparently, the crucial sentence is the last one in the NR section: ‘The |\partial| command sets the |Timing.measurePosition| property, which is a rational number that indicates how much of the measure has passed.’ I had tried to set measurePosition directly, but when used immediately before the new \time, neither 0 nor 4/4 worked as values. What does work as expected is inserting \partial 2. at the beginning of bar 2, so probably we should document that the ‘remaining length of the current measure’ given through \partial can’t be zero.

Yours, Simon


Yours, Simon

Am 16.08.2015 um 21:28 schrieb Mats Bengtsson:

I tried version 2.19.25 to typeset a piece that changes from 4/4 with an upbeat to 3/4 without an upbeat, in the middle of the piece. The new \partial handling worked for all parts, except a part that started with a multimeasure rest. Here's a small example illustrating the problem. Uncommenting the \bar line makes things slightly better but still wrong.
\version "2.19.25"
\relative c'{
\time 4/4
\partial 4
c |
d e f g |
%\bar "||"
\partial 4*0
\time 3/4
R2.*3 |
f4 ( a f ) |
R2.*3 |


bug-lilypond mailing list

reply via email to

[Prev in Thread] Current Thread [Next in Thread]