[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: no solution found for Bezier intersection

From: Thomas Morley
Subject: Re: no solution found for Bezier intersection
Date: Sun, 1 Jul 2018 22:40:27 +0200

2018-07-01 21:13 GMT+02:00 David Kastrup <address@hidden>:
> Colin Campbell <address@hidden> writes:
>> On 2018-07-01 11:47 AM, Thomas Morley wrote:
>>> Hi,
>>> the code below returns
>>> programming error: no solution found for Bezier intersection
>>> for 2.19.82 as well as for current master. 2.18.2 is ok.
>>> <snipped >
>>>   It's a heavily boiled down version of the original file (thus the
>>> strange octaves).
>>> Though I'm not able to boil it down even more.
>>> The error-message is obviously created in bezier.cc, no clue what's the 
>>> problem.
>> It gets even more strange, Harm: your code runs without error under
>> 2.21.0. When I tried playing with the forced octaves (e.g. the c, in
>> bar 6), I could reliably trigger the error, although only for the
>> octave down marks, not for octave up. It was repeatable up to bar 17
>> and never happened after that bar. I noticed that bar 17 had q1*3 and
>> produced 2 empty bars, so I changed bar 17to q1 q q which eliminated
>> the bezier error in the whole snippet, including in bars where it was
>> absolutely repeatable before that change.
>> I readily grant that I'm just poking a hornets' nest with a stick, but
>> maybe it gives at least a work around for your project.
> Perhaps try running under a debugger and setting a breakpoint on
> ::warning (or so)?  Then make a traceback when the warning is reached
> (hopefully from the right point).
> --
> David Kastrup

Well, I don't know what I should do. I never did something like this.

But I tried:

gdb lilypond/usr/bin/lilypond
(gdb) break ::error
Breakpoint 1 at 0x7ffff5b20390: file error.c, line 294.
(gdb) run file-bug.ly
(gdb) bt
No stack.

Probably I did it not correctly.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]