bug-lilypond
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Disappearing dynamics


From: Carl Sorensen
Subject: Re: Disappearing dynamics
Date: Tue, 13 Nov 2018 18:08:15 +0000
User-agent: Microsoft-MacOutlook/10.10.3.181015

Have you tried changing the lilypond call in Frescobaldi to a gdb lilypond 
call, so that you can pause the execution of lilypond and give Frescobaldi time 
to do whatever it might do -- and then continue lilypond from the debugger?

Have you tried changing the Frescobaldi options for displaying the pdf to get 
to a minimal Frescobaldi run that doesn't do much but generate the pdf?

This sounds like a truly bizarre bug.

Carl

´╗┐On 11/12/18, 4:46 PM, "Andrew Bernard" <address@hidden> wrote:

    Hi k\Kevin and All,
    
    It ranks as one of the most bizarre bugs I have ever seen (and I speak as a
    software developer of many decades). It's only with Frescobaldi. Command
    line compilation is fine. It's only dynamic markings, which is puzzling -
    whatever is going on? Running sync of course I tried, thinking the same as
    you. but to no effect. Once the dynamics appear, then they continue to
    appear.
    
    A mystery of the cosmos. Perhaps dynamic markings have become shy or
    recalcitrant. It's difficult to know how to debug this. Same behaviour in
    printing Debian 9.6 and Ubuntu 18.10.
    
    Andrew
    
    
    On Tue, 13 Nov 2018 at 09:37, Kevin Barry <address@hidden> wrote:
    
    >
    > How bizarre. I wonder what difference there could possibly be that
    > would make files appear to have different content. Does this issue
    > occur in Frescobaldi if opening after a successful (i.e. dynamics
    > appear correctly) compile from the cli and without making any edits?
    > Does running sync before compilation make any difference? Do dynamics
    > ever disappear after they have successfully appeared once?
    >
    >
    
    


reply via email to

[Prev in Thread] Current Thread [Next in Thread]