[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: Segfault when using specific symbol combination

From: Mathias Bockwoldt
Subject: RE: Segfault when using specific symbol combination
Date: Mon, 9 Mar 2020 09:42:05 +0000

Thank you for your quick response!

I tried Lilypond 2.20 now on Windows and Linux and the segfault disappeared. 
Sorry for the false alarm. I did not try 2.20 in the first place, because I did 
not find any bug report and thought that the error appears under such specific 
circumstances that it is unlikely to be discovered. But apparently, it was 

Just in case you are still interested, here is the Lilypond 2.18 output:

$ lilypond bugreport.ly
GNU LilyPond 2.18.2
Processing `bugreport.ly'
Interpreting music...
Preprocessing graphical objects...Segmentation fault (core dumped)


-----Original Message-----
From: Federico Bruni <address@hidden> 
Sent: 06 March 2020 16:34
To: Mathias Bockwoldt <address@hidden>
Cc: address@hidden
Subject: Re: Segfault when using specific symbol combination

Il giorno ven 6 mar 2020 alle 11:38, Mathias Bockwoldt <address@hidden> ha 
> Dear Lilypond team,
> I found a symbol combination that triggers a segfault in Lilypond
> 2.18.2 on Linux (Linux subsystem for Windows 10). I did not have the 
> chance to reproduce on other machines or with other versions.
> I tried looking for the bug in the database and I am 98% sure that it 
> is not there, yet.
> More information about the actual circumstances for the bug is in the 
> attached file.
> Thank you for this great product!
> Mathias

Can you paste lilypond output here?

I cannot reproduce it using "native" Linux and lilypond 2.20.
Your example compiles without errors.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]