[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: errors when updating syntax on Mac

From: Jonas Hahnfeld
Subject: Re: errors when updating syntax on Mac
Date: Sat, 30 Jan 2021 10:12:20 +0100
User-agent: Evolution 3.38.3

Am Samstag, dem 30.01.2021 um 02:39 -0500 schrieb James B. Wilkinson:
> I had a file claiming to be version 2.18 and opened it in Lilypond 2.22 on a 
> MacBook Pro running Mavericks. When I chose "Update syntax” from the Compile 
> menu, lilylib.py threw errors indicating that Python 2 was running and not 
> Python 3. I added a line to that file asking it to print the version and got 
> 2.6.6 from Apple. On a suggestion from the users’ list I found convert-ly.py 
> buried in the Lilypond.app directory structure and ran it from the terminal 
> on my file. It worked like a champ. The resulting updated file compiled with 
> no errors.
> The user’s list said that I should report the problem on this mail group.

This is a "known" issue, see
This cannot be solved until somebody with a Mac builds a new version of
LilyPad. Until then, don't use it and switch to Frescobaldi or any
other graphical editor instead.


Attachment: signature.asc
Description: This is a digitally signed message part

reply via email to

[Prev in Thread] Current Thread [Next in Thread]