[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

LilyPond 2.22.1 convert-ly adds blank lines when converting 2.18.0 using

From: Stu McKenzie
Subject: LilyPond 2.22.1 convert-ly adds blank lines when converting 2.18.0 using Windows 10 Home
Date: Wed, 12 Jan 2022 11:02:06 -0800
User-agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:91.0) Gecko/20100101 Thunderbird/91.4.1

There's been discussion about a similar issue during 2016, but this is the first time in years that I've tried to upgrade to the latest version.

Environment: Microsoft Windows 10 Home, Version 10.0.19043 Build 19043.

I've installed the following versions of LilyPond, with the result listed:
Version Result
2.20.0   does not add blank lines.
2.22.0   adds blank lines.
2.22.1   adds blank lines.

I haven't tried interim versions 2.21.0 or 2.21.2.  I thought it best to concentrate on the latest release.

I've simplified the test file down to a "Tiny Example" of 2 lines (filename Simply2Lines.ly):
\version "2.18.0"
% Single line comment.

Using Command Prompt, in the folder containing the LilyPond file, I used the command: "C:\Program Files (x86)\LilyPond\usr\bin\python" "\Program Files (x86)\LilyPond\usr\bin\convert-ly" -e Simply2Lines.ly

The Command Line OUTPUT was:
convert-ly (GNU LilyPond) 2.22.0

convert-ly: Processing `Simply2Lines.ly'...
Applying conversion: 2.19.2, 2.19.7, 2.19.11, 2.19.16, 2.19.22, 2.19.24, 2.19.28, 2.19.29, 2.19.32, 2.19.39, 2.19.40, 2.19.46, 2.19.49, 2.20.0, 2.21.0, 2.21.2, 2.22.0

The resultant file now has 3 lines (one blank line between the original lines):
\version "2.22.0"

% Single line comment.

All files converted with 2.22.0 or 2.22.1 have extra blank lines inserted between every original line.

The desired behavior is to change the version string and only the relevant LilyPond commands without adding blank lines.

As an aside, I've noticed that some installs for Windows provide a file named convert-ly, and others provide a file named convert-ly.py.
That's the reason that I had to use
    "C:\Program Files (x86)\LilyPond\usr\bin\python" "\Program Files (x86)\LilyPond\usr\bin\convert-ly"
instead of just
    "\Program Files (x86)\LilyPond\usr\bin\convert-ly"
when convert-ly.py exists.
There appears to be no consistency in the Windows release versions. i.e. convert-ly or convert-ly.py.

Should I raise another/separate bug report for this?

reply via email to

[Prev in Thread] Current Thread [Next in Thread]