[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Stave drawing behavior after a key change without following notes change

From: Tobias Leupold
Subject: Stave drawing behavior after a key change without following notes changed in 2.19.16
Date: Wed, 05 Oct 2022 21:30:45 +0200

Hi all!

After quite some time, I re-rendered some of my Lilypond sheets and tried to 
update them from some 2.18 version to Gentoo's current stable 2.22.0.

I noticed that after a key change without following notes, the stave is no 
longer drawn under the following signs.

I tracked this down, it happened with version 2.19.16.

Here's a minimalistic example to reproduce it:

    \version "2.19.15"
    \score {
        \new Staff {
                \key g \major c'1 \key a \major

This is still rendered correctly using version 2.19.15, cf. the attached 
lilypond-2.19.15.png screenshot.

With version 2.19.16, the stave is no longer extended behind the bar 
(compiling the same code, but with '\version "2.19.16"' set), cf. the 
lilypond-2.19.16.png screenshot.

This still happens with version 2.22.2.

So ... is this a bug, or is this a feature?! I would not have expected 
something like this to happen in a bugfix release, and I also didn't find any 
change documentation about this ...

If this was intended then sorry for the spam; but how can I get the old (way 
more meaningful) behavior back? If not: How can this be worked around?

Thanks for all help and/or fixes!

Cheers, Tobias

Attachment: lilypond-2.19.15.png
Description: PNG image

Attachment: lilypond-2.19.16.png
Description: PNG image

reply via email to

[Prev in Thread] Current Thread [Next in Thread]