[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Unterminated string error

From: John Alvord
Subject: Re: Unterminated string error
Date: Wed, 04 Apr 2001 21:59:50 GMT

On Tue, 03 Apr 2001 00:08:45 GMT, address@hidden (John Alvord) wrote:

>This is a gnu make 3.79.1, freshly gotten from the archives - date was
>June 2000 if I remember. I am work on upgrading from 3.75 to 3.79.1.
>There were a few small repairs needed, but it mostly looks OK.
>This is on NT 4, using sh.exe for a command shell.
>Given the following makefile
>       echo "* "
>That is an asterisk followed by a blank. I am getting "Syntax error:
>unterminated quoted string" display immediated after the echo. If I
>leave off the trailing blank...
>       echo "*"
>There is no error message produced.
>This problem was not observed on 3.75.
>I tried using bugs.gnu.org but couldn't get it to return anything from
>the queries.

Just a cleanup note. The problem was an obsolete sh.exe. The new make
used a different combination of quotes and escaped quotes. That failed
on the old sh.exe and worked fine on the new sh.exe.

Incidently, after some hunting I discovered that sh.exe is in the
cygwin "ash" package.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]