[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Make version 3.79.1 Linux Redhat 8.0

From: Jeff Burke
Subject: Make version 3.79.1 Linux Redhat 8.0
Date: Wed, 30 Apr 2003 09:07:52 -0400

        When setting the .LIBPATTERNS variable in my makefile.
.LIBPATTERNS :=lib%.so.0.0 lib%.so lib.a        ←Actuall line from global 

        I can do a make -p and see that the variable has changed from the 
lib%.so lib%.a to the new settings lib%.so.0.0 lib%.so lib.a.
# makefile (from `../../../global_include.mk`, line 216)        ←Actuall line 
from make –p command
.LIBPATTERNS :=lib%.so.0.0 lib%.so lib.a        ←Actuall line from make –p 

        Here is where the problem begins.  Any library I try to link in with 
the -L${LIB_DIR}
-l{libWHATEVER.so.0.0} it will find all the lib%.so and lib%.a fine but any
lib%so.0.0 in the {LIB_DIR} path it will not find at all. I also tried adding a 
vpath for
%.so.0.0 to the ${LIB_DIR} but that still doesn’t work.

        I can get the library to link in only adding the whole path and image 
name on the 
Cc -Xlinker line.

        The RPM package installed is the make-3.79.1-14

Please let me know if you need any more details on this issue.

Thanks Jeff

This email message and any files transmitted with it contain confidential 
information intended only for the person(s) to whom this email message is 
addressed.  If you have received this email message in error, please notify the 
sender immediately by telephone or email and destroy the original message 
without making a copy.  Thank you. 

reply via email to

[Prev in Thread] Current Thread [Next in Thread]