[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

bug: expand.c:489:allocated_variable_append: Assertion 'current_variable

From: lightspeed
Subject: bug: expand.c:489:allocated_variable_append: Assertion 'current_variable_set_list->next != 0' failed
Date: Mon, 25 Aug 2003 09:58:51 +0300 (EEST)

   This is my third bug report, so please excuse me for giving you too much
or too few information. Please if you have the time give me advices how to
write bug-reports in the future(what is good/wrong with this one). I tried
to follow the bug-reporting specified in make's documentation.

THE BUG: If I set the environment variable CFLAGS="-O3 -march=k6-2" and then
run make in coregrind/demangle I get the following message, wich I believe
is an internal error in make:
   make: expand.c:489: allocated_variable_append: Assertion
current_variable_set_list->next != 0' failed.
        I ran make with that environment variable set,because before that
ran ./configure --with-x , and immediately afterwards I ran make.
        If I ran make without CFLAGS set everything goes ok, and this is
only bug I've seen in make since I'm using it (2-3 years).
!!!!the files are in files.tar.gz:!!!!!!!
the makefile is coregrind/demangle/Makefile, the files are from the valgrind
I've also included a dump of my environment as attachment.

        Sample session that triggers the bug:
//------------beginning of sample session-----------//
address@hidden tmp]$ export CFLAGS="-O3 -march=k6-2"
address@hidden tmp]$ cd coregrind/demangle
address@hidden demangle]$ make
if gcc -DHAVE_CONFIG_H -I. -I. -I../..  -I../../coregrind -I../../include
-O3 -march=k6-2  -Winline -Wall -Wshadow -O -fomit-frame-pointer -g
-mpreferred-stack-boundary=2 -Wno-unused -Wno-shadow  -MT cp-demangle.o -MD
-MP -MF ".deps/cp-demangle.Tpo" \
  -c -o cp-demangle.o test -f 'cp-demangle.c' || echo './'cp-demangle.c; \
  then mv ".deps/cp-demangle.Tpo" ".deps/cp-demangle.Po"; \
  else rm -f ".deps/cp-demangle.Tpo"; exit 1; \
  make: expand.c:489: allocated_variable_append: Assertion
current_variable_set_list->next != 0' failed.
address@hidden demangle]$
//-------------end of sample session-----------//

!!!!! make version is:3.79.1
Built for i386-redhat-linux-gnu

>> output of uname -a:
Linux localhost.localdomain 2.4.20-8 #1 Thu Mar 13 16:42:56 EST 2003 i586
i586 i386 GNU/Linux
>> /etc/redhat-release:
Red Hat Linux release 9 (Shrike)

processor       : 0
vendor_id       : AuthenticAMD
cpu family      : 5
model           : 8
model name      : AMD-K6(tm) 3D processor
stepping        : 12
cpu MHz         : 267.278
cache size      : 64 KB
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 1
wp              : yes
flags           : fpu vme de pse tsc msr mce cx8 pge mmx syscall 3dnow
bogomips        : 532.48

Thanks for reading this bug-report.
I'm waiting for replys to: address@hidden, or address@hidden

            Torok Edwin

Get your free email adress and webhosting at http://www.as.ro .

Attachment: files.tar.gz
Description: application/gzip-compressed

Attachment: environment
Description: Text document

reply via email to

[Prev in Thread] Current Thread [Next in Thread]