[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Bug in make...

From: santhosh km
Subject: Bug in make...
Date: Mon, 7 Jun 2004 00:06:08 -0700 (PDT)


I am trying porting of c files to VxWorks thru cygwin
using the GNU-Make Version 3.80 .
I have a problem while using makefile. The problem is
the commond:
        "ccsimpc -o HELLO_WORLD helloWorld.c"
works on the command line and I get the HELLO_WORLD
executable file.
But doesn't work thru makefile, I get the error as:
make: *** [x] Error 1

Here the ccsimpc is equivalent to gcc, but ccsimpc is
the compiler for VxWorks.

My make file helloWorld.mk, which has one target and
one line is

        ccsimpc -o HELLO_WORLD helloWorld.o


1) I read in the manuals that "make invoked a command
which returned non-zero error code".
   for this I got echo $? as 0, after executing
ccsimpc thru command line.

2) I also read in the manuals that errors in the
commands, does not indicate an error. For that
   I tried -i and -k options but no output was

3) When I tried with -d option the end lines said
"Updating goal targets....
Considering target file `x'.
 File `x' does not exist.
 Finished prerequisites of target file `x'.
Must remake target `x'.
ccsimpc -o HELLO_WORLD helloWorld.o
Putting child 0x1002aeb8 (x) PID 2648 on the chain.
Live child 0x1002aeb8 (x) PID 2648
Got a SIGCHLD; 1 unreaped children.
Reaping losing child 0x1002aeb8 PID 2648
Removing child 0x1002aeb8 PID 2648 from chain."

I don't know what to do for this problem

4) And also I tried this first on make -version 3.79.1
it didn't work, then I found the new version
  3.80 on the gnu site and tried on that, but the same

Please let me know the answer ASAP so that I can

Thanks in advace & Regards,

Do you Yahoo!?
Friends.  Fun.  Try the all-new Yahoo! Messenger.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]