[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Make fails on glibc build

From: Jon Grant
Subject: Re: Make fails on glibc build
Date: Fri, 18 May 2007 23:51:56 +0100
User-agent: Thunderbird (X11/20070103)


address@hidden wrote on 18/05/07 15:08:
I rebuilt it and the error came again. Using make from cvs 20070511, binutils from 
cvs, glibc from cvs 20070518, gcc-4.2.0, kernel,  i686 (make 3.81 works). Using CFLAGS 
"-march=pentium4 -O2 -pipe -fomit-frame-pointer -s" and configure "--prefix=/tools 
--disable-nls --disable-dependency-tracking --infodir and --mandir".
make -d gives me:

       Trying rule prerequisite `subdir_lib'.
make: file.c:147: enter_file: Assertion `*name != '\0'' failed.
Reaping losing child 0x0807f1b8 PID 9716
make: *** [all] Aborted
Removing child 0x0807f1b8 PID 9716 from chain.

Because I disabled debug for make I rebuilt it with standard CFLAGS. But how 
can I help you to solve the problem?
Never worked with a debugger yet.

Do you mean you have never worked with a debugger?

I'm not certain, but that assertion should then call abort(), which means a core file will be dumped. (Just do ulimit -c 50000 in your shell before you run make, to be sure core files are not disabled on your distro).

then you can do gdb -c core.xxx -se /path/to/make

then "bt" to get the backtrace of the assert.

Cheers, Jon

reply via email to

[Prev in Thread] Current Thread [Next in Thread]