[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: make error but no message

From: Jeremiah Perry
Subject: Re: make error but no message
Date: Thu, 12 Mar 2009 15:17:35 -0700

I'm using 3.81 on cygwin. I found the problem on a prebuilt binary,
then I compiled make from source today (on cygwin) to see if the
problem would go away but it didn't. I suppose it could be a cygwin
problem....I'll try running it on Linux when I get home tonight.


On Thu, Mar 12, 2009 at 3:02 PM, Sam Ravnborg <address@hidden> wrote:
> On Thu, Mar 12, 2009 at 02:07:56PM -0700, Jeremiah Perry wrote:
>> Hi,
>> I don't know if the following is a bug or not, but it came to my
>> attention recently. I ran make on a project only to have make stop
>> abruptly with no error messages. After some digging, I found one of my
>> dependencies referred to a non-existent file. My dependency rules are
>> in .d files that I then -include into the makefile. See the code
>> example below. It seems this -include throws make off somehow so it
>> doesn't issue any error messages. However, when I put the dependencies
>> explicitly into the makefile, make tells me "*** No rule to make
>> target `doesnt_exist.h', needed by `test.o'. Stop.", so that seems to
>> be fine.
> I tried it here.
> With make 3.80 it works as expected. I do not have 3.81 handy right now.
> Which version of make did you use?
>        Sam

reply via email to

[Prev in Thread] Current Thread [Next in Thread]